0

Just bought a new laptop acer predator helios 500 with AMD Ryzen CPU. Installed linux with a recent kernel (4.19) and it seems it’s not able to detect when the power cable is connected to the laptop.

I’ve read other troubleshooting posts in which the problem is only when the cable is connected after booting, or not recognized after connecting and disconnecting, but for me the problem occurs regardless of whether is booted on cable or not, connected/disconnected, laptop lid opened/closed, etc.

The power however doesn’t seem to be running out – that is, it won’t drop below the number that appears when the laptop is started – but as it’s taken to be on battery it triggers power saving settings (while being plugged to an electricity source).

I tried installing different modules such as acpi-support, but it didn’t work.

0

This seems to be an issue with upower. I would recommend upgrading to the newest upower-git if your distribution has it. I personally just uninstalled xfce4-power-manager You may also want to try changing: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash processor.ignore_ppc=1" in /etc/default/grub and see if that helps any.

  • Upgrading upower didn't help unfortunately, but thanks for the tip about limited CPU frequencies. – anymous.asker Mar 26 at 11:12
  • 1
    I have learned a few more tricks, since I have the AMD Predator 500. If you boot and your CPU is stuck at around 500MHz then try unpluggin/replugging the cord. Try installing TLP and mess with the settings there to get a little more performance and see if you can set your CPU to the "ondemand" governor using the cpupower tool. For the GPU look into amdgpu-utils. You will need to add another boot option but it will allow you to set your battery-save state "P0" to a higher clock and get the full performance out of the graphics card. – quad cricket Mar 27 at 15:23
  • That thing about reconnecting the power cord worked. That's a really messed up bug! Now I get more than the 3.2Ghz without having overclocked. Any way of making it permanent without having to touch the cable? – anymous.asker Mar 27 at 20:44
  • Not that I have found, unfortunately. I have posted in the Acer community forums and they left it at "Since the adapter works fine in Windows it's not our problem.". – quad cricket Mar 28 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.