0

When I install the stacks in my Ubuntu 16.04:

...
checking for sqrt... no
checking for functional regular expressions... configure: error: Regular expressions are not functional, you need g++ 4.9.0 or greater.

I check my g++ there is 8.2.0:

suser@suser-S2600CP[stacks-1.48] g++ -v                           [10:34] 
using specs.
COLLECT_GCC=g++
COLLECT_LTO_WRAPPER=/usr/local/libexec/gcc/x86_64-pc-linux-gnu/8.2.0/lto-wrapper
target:x86_64-pc-linux-gnu
configure:../configure -enable-checking=release -enable-languages=c,c++ -disable-multilib
threading model:posix
gcc version 8.2.0 (GCC) 
  • I'm not able to reproduce this. I was able to build stacks using gcc8 on Ubuntu 18.10 with no issues. Is your gcc and g++ source compiled or installed via apt? Add the output of ls -l $(which gcc) to your question. – Nasir Riley Mar 21 at 3:25
  • I use the /usr/local/bin/gcc gets the gcc 8.2.0. – 244boy Mar 21 at 6:04
  • From the output of g++ -v, it looks like you built it from source. Do you have the libraries appended to your LD_LIBRARY_PATH environment variable? – Nasir Riley Mar 21 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.