0

I am using vim-gtk on Ubuntu 16.04 and use exuberant-ctags to generate a tags file in the root directory of my project. My instance of vim would randomly freeze in insert mode, usually after inserting a full stop (.) and the only thing I could do is close that terminal and open a new instance of vim in a new terminal. I was able to narrow the problem down to something with ctags by removing things from my .vimrc file. When I remove set tags=tags;, vim works fine and never freezes. I have also noticed that if I remove the tags file in my root directory, it no longer freezes even though set tags=tags; is in the vimrc.

Things I have tried:

  • other questions mentioned Ctrl+S and Ctrl+Q. When it freezes in insert mode Ctrl+Q has no effect and I am sure I am not accidentally typing Ctrl+S since I have tried pressing it intentionally and then Ctrl+Q does work.
  • Uninstalling and reinstalling vim, vim-gnome, vim-gtk, etc...
  • Uninstalling and reinstalling exuberant-ctags

Neither of these fix the problem. Has anyone encountered this problem before? If there is no obvious fix, can anyone recommend an alternative to exuberant-ctags that can be used with vim without making it freeze on my machine?

0

Vim was freezing because my tags file was too large. I added several directories and filetypes to .agignore and then reran ctags using ctags -R --exclude=@.agignore which resulted in a much smaller tags file (19MB instead of 2GB) and now vim no longer freezes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.