0

Problem Description

The NVIDIA drivers on my laptop no longer seem to be working properly. This comes as a result of my laptop recently shutting down for a lack of battery. The power cord was not plugged in. Following the crash, the icon of the NVIDIA drivers in the task bar, usually showing which graphics card is in use, started displaying X with the corresponding tooltip reading Active graphics card: unknown. In addition, the drivers' settings can no longer be opened. More precisely, running nvidia-settings in the terminal yields the following error:

ERROR: Unable to load info from any available system

System Configuration

The configuration of my system is as follows:

  • Operating System: Linux Mint 18.3 Cinnamon 64-bit
  • Linux Kernel: 4.4.0-143-generic
  • NVIDIA drivers: nvidia-415 (nvidia-415.27-0ubuntu0~gpu16.04.1)

Furthermore, to give some information on the graphics cards available on my system, running inxi -G produces the following output:

Graphics:  Card-1: Intel HD Graphics 530
           Card-2: NVIDIA GM108M [GeForce 940MX]
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 2560x1440@60.00hz, 2560x1440@59.95hz
           GLX Renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) GLX Version: 3.0 Mesa 18.0.5

Approach So Far

I've tried the obvious thing, which is purging (through sudo apt-get purge nvidia*) and then (re)-installing the NVIDIA drivers. Interestingly, the task bar icon is now gone completely. Running nvidia-settings, however, still produces the same output.

I wonder whether this even is a software issue at all, or if one of the graphics cards instead has been damaged by the crash following the empty battery.

0
FAILED: nouveau

This indicates you have the open-source nouveau driver (or at least its kernel module) detected, instead of nvidia of the nvidia-415 package.

I wonder if the loss of power and the ensuing reboot caused a newer kernel version to be used, which then perhaps did not have the corresponding nvidia, nvidia_drm and nvidia_modeset modules compiled for it?

Please run sudo dkms status and paste the output to your question. If the output does not include a line like

nvidia, <nvidia version>, <your kernel version>, x86_64: installed

or if the last word on the line is something other than installed, that's the problem. You can try to fix it for your current kernel with sudo dkms install nvidia/<nvidia version>. Executing that command may take a while and heavily load your processor while it's running. If it's successful, try rebooting your laptop and see if it works after that.

  • I just realized that when re-installing the NVIDIA drivers, I switched to a different version, namely nvidia-384. Either way, running sudo dkms status yields, among others, the following line: nvidia-384, 384.130, 4.4.0-143-generic, x86_64: installed. Running sudo dkms install nvidia/<nvidia version> therefore doesn't seem to make any sense. – foobar Mar 20 at 19:41
  • Ah, the PPA names the module as nvidia-384. So the exact command line for compiling the current version of it for your current kernel would have been sudo dkms install nvidia-384/384.130 but since it's already compiled and installed for your current kernel, you don't need that command. – telcoM Mar 20 at 19:44
0

I was able to solve the issue as follows. In the terminal, I ran sudo prime-select nvidia. After rebooting, running nvidia-settings started working again as intended. The NVIDIA tray icon, however, was still missing, probably because I purged nvidia* in the process of trying to get to a solution. In any case, running sudo apt-get install nvidia-prime-applet and a subsequent reboot of the machine do the trick. Now everything seems to be in the pre-crash state once again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.