0

I've tried downloading the SCIM input method program. Normally I should be able to press CTRL+Space to switch languages, however, this hot-key is not working. How to enable Korean language typing and also to be able to display it in the terminal?

  • What do you mean by "be able to display it in the terminal"? The default language being Korean? – Paradox Mar 19 '19 at 0:44
0

Modifying keymaps

Method 1

You can setup keymaps, both for X11 and terminal, by modifying the file etc/default/keyboard.

If you want to setup English and Korean, and switching between both with ALT+SHIFT, you need to edit the following lines:

 XKBLAYOUT="us,ko"
 XKBOPTIONS="grp:alt_shift_toggle"

Method 2

You can use setxkbmap to define different keymaps and how to switch between them, such as following:

$ setxkbmap -layout us,ko -option grp:alt_shift_toggle

The command line above sets two differents keymaps en_US and ko_KO and enables to change between both with ALT+SHIFT.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.