-2

I am trying to make a startup script, but when I run top, I don't see it running. Here is my startup script:

#!/bin/bash
# /etc/init.d/mystartupscript.sh
cd /home/ubuntu/gvite
tmux new "sudo ./gvite"

I don't know what's happening, but when try to manually start it, I get these errors:

Warning: The unit file, source configuration file or drop-ins of mystartupscript.service changed on disk. 
● mystartupscript.service
   Loaded: loaded (/etc/init.d/mystartupscript.sh; generated)
   Active: failed (Result: exit-code) since Sun 2019-03-17 23:01:04 UTC; 9min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1322 ExecStart=/etc/init.d/mystartupscript.sh start (code=exited, status=1/FAILURE)
    Tasks: 0 (limit: 1152)
   CGroup: /system.slice/mystartupscript.service

Mar 17 23:01:04 ip-172-31-3-197 systemd[1]: Starting mystartupscript.service...
Mar 17 23:01:04 ip-172-31-3-197 mystartupscript.sh[1322]: open terminal failed: not a terminal
Mar 17 23:01:04 ip-172-31-3-197 systemd[1]: mystartupscript.service: Control process exited, code=exited s
Mar 17 23:01:04 ip-172-31-3-197 systemd[1]: mystartupscript.service: Failed with result 'exit-code'.
Mar 17 23:01:04 ip-172-31-3-197 systemd[1]: Failed to start mystartupscript.service.
lines 1-14/14 (END)

How can I fix this?

  • You probably don't need tmux...unless you at some point plan to connect to the service? And you don't need sudo since you're running as root. So I would just make the last line ./gvite – Stephen Harris Mar 17 at 23:15
  • Ok, I got it to work. Thanks! Also, now gvite cant find the data directory, so it is starting to sync all over again from the block 0. Can u help me plz? – Crypthusiast Mar 17 at 23:21
  • I have no idea what gvite is... but remember when a process is started from a service like this then it runs as root and inherits a minimal setup. So any configuration you have as your own user ("ubuntu") won't be picked up on. Some applications may allow a different configuration to be used; you'll need to read the documentation. – Stephen Harris Mar 17 at 23:23
  • Gvite is a daemon for a cryptocurrency full node, and needs its directory. When I run it from my usual terminal, it just goes where it left. It takes a long time to sync, and I need it to continue. Maybe there is a way to move the data directory somewhere where the system can find it? – Crypthusiast Mar 17 at 23:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.