3

Goal: boot up from fully installed debian 9 USB drive

I installed debian into my USB drive but it fails to recognize my USB in boot option. This is the link where I downloaded the iso file.

Below are what I have tried

  1. I tried to burn the iso into my first USB drive using Rufus

  2. I then try to boot from the USB live

  3. I run through the setup progress, burning the OS into my second USB. During the progress, it did not show any errors. (it was able to detect my second USB).

  4. However, after I finished the setup. It did not show up the second USB as one of the boot option.

I checked the boot sequence. My first priority is USB port. I repeated all the steps mentioned above on my friend laptop (Windows 10) and it worked on his laptop.

Update:

1) I unplugged the internal hard drive and setting up debian without it, it just tells me no bootable drive.

2) Run the checksum

C:\Users\PC\Downloads\ISO>certutil -hashfile debian-live-9.8.0-amd64-gnome+nonfree.iso MD5
MD5 hash of debian-live-9.8.0-amd64-gnome+nonfree.iso:
83436d6e797c75084dbeba203f5a818d
CertUtil: -hashfile command completed successfully.

it is the same as the official website.

3) I tried to copy the ESI files/EFI/boot and /EFI/debian from Windows and pasted it to the USB ESI partition

4) I also took out my second internal Hard Drive and inserted a new Hard drive to install Debian into it

2

Here is how I fixed it

This is how the files in the USB ESP partition should look like:

full-install USB  
  ESP partition  
    EFI  (directory)  
     Boot  (directory)  
       bootx64.efi
       grubx64.efi
       fbx64.efi
     debian  (directory)  
       grubx64.efi 

However there were NO EFI FILES in my USB after I finished installing (So please check your ESP partition!). So I have to copy the Boot folder and debian folder from Windows ESP parition and copy the grubx64.efi into Boot folder


  • Details about how to access EFI partition in Windows please check out this link
  • Details about how to access EFI partition in USB please check out this link

NOTE: to access the EFI partition in USB you have to use any Linux distros live USB and I was using Kali live USB.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.