Because of common issues with a laggy mouse, I decided to disable Wayland on my brand new installation of OpenSuse on my Desktop PC.

I had performance issues with Wayland, but when I selected "Gnome with Xorg" at login - everything worked fine later.

So I completely disabled Wayland by appending this line to the file /etc/gdm3/custom.conf


Since I don't have any lags on the login screen - no more "Gnome with Xorg" choice on the login settings.

But when I input my password and submit, I get a prompt black screen for a second, and then I get back to the login screen.

Do you know where I can gather logs for this issue and how I can fix that ?


The first place I would look for is: the .xsession-errors files in your login home folder.

cat .xsession-errors
cat .xsession-errors | more (large file)

It's the error log produced by your X windows system

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.