0

After changing a hardware and booting up same operating system(archlinux32) on it the sound doesn't work at all. On old hardware it worked well.

When migrated:

  1. Booted up a live ISO
  2. Ran mkinitcpio -p linux
  3. Updated /etc/fstab
  4. Reinstalled grub

After booting everything works fine except sound. Also pulseaudio and alsa-utils are installed.


speaker-test -c 2 -D default:

speaker-test 1.1.8

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Playback open error: -2,No such file or directory

lspci -nn | grep Audio:

00:1b.0 Audio device [0403]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller [8086:2668] (rev 03)

pactl list sinks:

Sink #0
        State: IDLE
        Name: auto_null
        Description: Dummy Output
        Driver: module-null-sink.c
        Sample Specification: s16le 2ch 44100Hz
        Channel Map: front-left,front-right
        Owner Module: 15
        Mute: no
        Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
                balance 0.00
        Base Volume: 65536 / 100% / 0.00 dB
        Monitor Source: auto_null.monitor
        Latency: 658477 usec, configured 2000000 usec
        Flags: DECIBEL_VOLUME LATENCY
        Properties:
                device.description = "Dummy Output"
                device.class = "abstract"
                device.icon_name = "audio-card"
        Formats:
                pcm

aplay -l:

**** List of PLAYBACK Hardware Devices ****

lsmod | grep snd:

snd_hda_codec_realtek   102400  1
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
snd_hda_intel          40960  0
snd_hda_codec         118784  3 snd_hda_intel,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           73728  4 snd_hda_intel,snd_hda_codec,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               102400  3 snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              32768  1 snd_pcm
snd                    73728  7 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_timer,snd_hda_codec_generic,snd_hda_codec_realtek,snd_pcm
soundcore              16384  1 snd

systemctl --user status pulseaudio.socket:

* pulseaudio.socket - Sound System
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.socket; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2019-03-17 21:09:12 EET; 14min ago
   Listen: /run/user/1000/pulse/native (Stream)
   CGroup: /user.slice/user-1000.slice/user@1000.service/pulseaudio.socket

Mar 17 21:09:12 ninmach systemd[381]: Listening on Sound System.
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

alsamixer:

img2


alsamixer with chosen HDA Intel card:

img3


alsamixer with pressed F5:

img4


pavucontrol:

img1


pavucontrol with Configuration tab:

img5

All in all, why could it doesn't show Master or such in alsamixer and doesn't work at all.

This is an old Foxconn 915A03-G-8KS motheboard with single cored Intel(R) Celeron(R) CPU 2.66GHz CPU.

0

Some good person on IRC channel #archlinux32 helped telling that a solution might be an option for snd-hda-intel kernel module: model=6stack or model=6stack-digout.

So, after reloading this module with option everything worked:

modprobe -r snd-hda-intel
modprobe snd-hda-intel model=6stack

This might be a bug in kernel, so it loads this module without a proper option and, also, a patch doesn't work for that motherboard.

Although, adding this option manually to /etc/modprobe.d/ will tell system to load this module with this option every next boot:

echo "options snd-hda-intel model=6stack" >> /etc/modprobe.d/sound_fix.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.