1

I am trying to create new profile via Terminal for firefox and am using this command:

firefox -createprofile 'profile'

It looks like everything is fine, but I can't find any new file by using ls | grep "profile"

While using

./firefox -profilemanager

Firefox is openning on blank page, by checking in help -> Troubleshooting information -> Profile directory, there is always same directory / name of folder.

By using

firefox -profile "profile"

the same thing happens.

I have tried to use uppercase version as well as lowercase; both work and open Firefox. What am I doing wrong?

I tried using firefox -P or -p , there is also no visual difference (as how is firefox acting, where redirecting and what profile applying)

Also by using ls ~.mozilla/firefox and opening with VI profiles.ini , I can see that there is only one profile there (which was created by default)

My current directory is /home/username/.mozilla/firefox.

0

-createprofile is not a valid command-line argument for starting Firefox. To create a new profile, you start by launching the Profile Manager by running firefox --ProfileManager. If you already have an instance of Firefox running (there could be an errant process running in the background; check this with ps -u) , you can add the --no-remote to start a new instance:

firefox --ProfileManager --no-remote

You can then start the Create Profile Wizard by clicking on the Create Profile button. This will create a new profile in ~/.mozilla/firefox/.

  • This solution helped me, thank you. – Gifciak Mar 15 at 17:48
  • You're welcome. Accepting the answer was sufficient thanks. Later (when you get more reputation), you'll also be able to upvote answers. On that note, have an upvote for clearly explaining your problem in the question body - and for showing what you've already tried/researched. Welcome to Unix & Linux! – Anthony Geoghegan Mar 15 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.