1

Everything works, but when I reboot via "systemctl reboot" or through GNOME, it will never actually reboot, but instead it gets stuck in a black screen with blinking underscore cursor, and I am forced to do a hard-reset.

These are the last entries in the journalctl -r:

Mar 14 23:07:29 Desktop systemd-journald[417]: Journal stopped
Mar 14 23:07:29 Desktop systemd-shutdown[1]: Sending SIGTERM to remaining processes...
Mar 14 23:07:29 Desktop systemd-shutdown[1]: Syncing filesystems and block devices.
Mar 14 23:07:29 Desktop kernel: printk: systemd-shutdow: 50 output lines suppressed due to ratelimiting
Mar 14 23:07:29 Desktop systemd[1]: Shutting down.
Mar 14 23:07:29 Desktop systemd[1]: Reached target Reboot.
Mar 14 23:07:29 Desktop audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-reboot comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Mar 14 23:07:29 Desktop audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-reboot comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Mar 14 23:07:29 Desktop systemd[1]: Started Reboot.
Mar 14 23:07:29 Desktop systemd[1]: systemd-reboot.service: Succeeded.
Mar 14 23:07:29 Desktop systemd[1]: Reached target Final Step.
Mar 14 23:07:29 Desktop systemd[1]: Reached target Shutdown.
Mar 14 23:07:29 Desktop systemd[1]: Removed slice system-systemd\x2dfsck.slice.

Any idea why this is happening?

EDIT: It seems that it actually does reboot after exactly 2 minutes each time. So I think it may be waiting for some process to end? This happens every time though, even when rebooting right after booting into the DM. Could be X11 related?

Here is the journalctl -r:

Mar 16 20:53:23 Desktop kernel: Linux version 5.0.2-arch1-1-ARCH (builduser@heftig-15298) (gcc version 8.2.1 20181127 (GCC)) #1 SMP PREEMPT Thu Mar 14 18:47:49 UTC 2019
-- Reboot --
Mar 16 20:51:24 Desktop systemd-journald[419]: Journal stopped
1

I was having the same problem, I fixed it by changing

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

in

/etc/default/grub

and then running

# grub-mkconfig -o /boot/grub/grub.cfg

source

  • Unfortunately that did not work. I did, however, go through all combinations of "reboot=pci" and "reboot=b", etc, but to no avail. I edited the original post. It seems that it is actually booting, but it takes 2 minutes. Maybe it's waiting for some weird process to finish? I cannot find any info on this – Muppet Mar 17 at 0:58
  • have you tried without the "quiet" parameter in grub_cmdline_linux_default in /etc/default/grub to see what process it is stuck on? – remoof Mar 17 at 1:21
  • 1
    yeah the last msg is "Target reached Reboot" – Muppet Mar 17 at 17:46
  • have you come across this freedesktop.org/wiki/Software/systemd/Debugging/#index3h2 – remoof Mar 17 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.