1

I am trying to install latest, stable Chrome on Debian and get the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 google-chrome-stable : Depends: libappindicator3-1 but it is not installable
                        Recommends: libu2f-udev but it is not installable
E: Unable to correct problems, you have held broken packages.

I am running the following version of Debian:

No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 8.11 (jessie)
Release:    8.11
Codename:   jessie

I have already used

 apt-get update

followed by

 apt-get dist-upgrade

but get the same error during Chrome installation.

Any idea how to get this installed?

1
  • 1
    what is the contents of your sources.list? Please edit your post to contain these details.
    – kemotep
    Mar 14 '19 at 20:42
1

try and update to debian 9 stetch then install chromium form the debian repositories

1
  • have you got it working yet? if not try following GAD3R advice
    – qblueRed42
    Mar 15 '19 at 12:25
1

To install google chrome on debian jessie through the package manager apt, you should have the following lines in your /etc/apt/sources.list:

deb http://deb.debian.org/debian/ jessie main
deb http://deb.debian.org/debian/ jessie-updates main
deb http://deb.debian.org/debian-security jessie/updates main

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

then add the signing key:

wget -q -O - https://dl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

Install google-chrome:

sudo apt-get update
sudo apt-get install google-chrome-stable

The package libu2f-udev is a Recommends dependencies only available for debian buster/Sid.

The libappindicator3-1 package will be installed through apt as dependency.

2
  • Strange thing is that my /etc/apt/sources.list is empty. Why would that be?
    – user298115
    Mar 17 '19 at 13:12
  • @TitusQuinn I think during the system install apt isn't configured correctly. (without internet connection or the apt configuration is skipped)
    – GAD3R
    Mar 17 '19 at 13:21
0

when you install chrome, skype or any.deb and you encounter this problem just run "apt install -f"

sudo apt install -f

this will fix the problem or remove the broken package if no chance.

1
  • Tried this and still get the same error.
    – user298115
    Mar 14 '19 at 20:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy