0

Today I installed the latest version of Manjaro i3 18.0.3 to my MSI GE-60PC laptop which has GeForce GTX 850M. I'm using my laptop with external Monitor (connected via HDMI). After first boot, my laptop screen and external monitor were mirrored. I wasn't able to set my display settings. Then I installed the nvidia package1 using pacman with the following command.

sudo pacman -S linux419-nvidia

My kernel version is;

Linux my-msi 4.19.28-1-MANJARO #1 SMP PREEMPT Sun Mar 10 08:32:42 UTC 2019 x86_64 GNU/Linux

In 1, it says;

5. Reboot. The nvidia package contains a file which blacklists the nouveau module, so rebooting is necessary. 

So, i rebooted the pc after installing nvidia drivers. After reboot, my display settings was fixed, so my monitor was extended. Although, when I run the following command;

lspci -k | grep -A 2 -E "(VGA|3D)"
0:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
    DeviceName:  Onboard IGD
    Subsystem: Micro-Star International Co., Ltd. [MSI] 4th Gen Core Processor Integrated Graphics Controller
--
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 850M] (rev a2)
    Subsystem: Micro-Star International Co., Ltd. [MSI] GM107M [GeForce GTX 850M]
    Kernel driver in use: nouveau

It says I'm still using nouveau driver. What is the proper and correct way to install nvidia drivers? I want to install cuda and pytorch after that.

When I run nvidia-modprobe command, the following kernel log occur.

[ 1883.794671] nvidia-nvlink: Nvlink Core is being initialized, major device number 237
[ 1883.795017] NVRM: The NVIDIA probe routine was not called for 1 device(s).
[ 1883.795018] NVRM: This can occur when a driver such as: 
               NVRM: nouveau, rivafb, nvidiafb or rivatv 
               NVRM: was loaded and obtained ownership of the NVIDIA device(s).
[ 1883.795018] NVRM: Try unloading the conflicting kernel module (and/or
               NVRM: reconfigure your kernel without the conflicting
               NVRM: driver(s)), then try loading the NVIDIA kernel module
               NVRM: again.
[ 1883.795018] NVRM: No NVIDIA graphics adapter probed!
[ 1883.795132] nvidia-nvlink: Unregistered the Nvlink Core, major device number 237
1
  • You can run mhwd-tui from command line or Manjaro Settings Manager in X/Wayland for installing and seeing status of nVidia driver.
    – raspi
    Commented Mar 9, 2023 at 5:43

2 Answers 2

1

Similar question: https://bbs.archlinux.org/viewtopic.php?id=213042 Try blacklisting the following modules and reboot:

blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv
blacklist nv
blacklist uvcvideo
-1

You can download the NVIDIA Linux driver from here. After the download has finished, run

sudo init 3

Which will take you to multi user without a desktop environment. Now, enter your user name and password, cd to your NVIDIA driver directory, and then run this to install the driver:

sudo ./nvidia-driver-name

When that finishes, run:

sudo init 5

The desktop environment will appear. I hope this solves your problem.

1
  • On Arch linux $ sudo init 3 yields: "Excess arguments. " Are you referring to the legacy SysV execution levels for runtime ??
    – Cbhihe
    Commented May 24, 2020 at 14:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .