2

I'm currently trying to install PCP on Debian with sparc64. Unfortunately it requires the package libreadline6 (>= 6.0) which doesn't have an apt package for sparc64. libreadline7 does and is installed.

My solution was building gnu readline v6.3 from source (which worked), however I'm unsure how to proceed from here. Installing PCP via apt again lists the missing libreadline6 dependency. Is there another solution to this, other than building PCP completely from source as well?

  • I am sure that you can "hack" by using dpkg properties to make it understand that the package you built by source is already installed via source and commands like dpkg-deb --build... Have a look here if you think this method could help you: linuxconfig.org/… ... I am not really an advanced linux user, so, feel free to ask me delete my comment. Just thought to share the idea but risked to be a stupid idea (even if I still feel it can be done with the inner method that dpkg is looking for the installed packages) – koleygr Mar 14 at 21:28
2

The simplest option for you is to download libreadline6 from the Debian snapshots archive; there’s a copy of the sparc64 package there.

If you want to build it from source, I’d recommend building from the readline6 source package. I can expand on that if necessary.

  • thanks that worked perfectly. however, what do you do, if theres no snapshot or port available? for example, the same package requires libpcp-pmda-perl, which requires perlapi-5.22.1, which again has no working package for sparc64 (altough according to packages.debian.org/sid/perl/libpcp-pmda-perl it should have, but isn't available for some reason) – nn3112337 Mar 14 at 16:31
  • Welcome to the world of non-release ports :-/. Any package pushed to Debian archives should be available from snapshots, but some ports never get built and the underlying issues won’t necessarily be fixed. pcp hasn’t been rebuilt since we moved away from Perl 5.22, so it still depends on perlapi-5.22.1 which used to be provided by perl-base 5.22.1. Fixing that would involve rebuilding it with the current Perl. That hasn’t been done because sparc64 doesn’t have some of the necessary dependencies (see here). – Stephen Kitt Mar 14 at 16:45
  • So the only solution is finding a perl-base 5.22.1 snapshot or building perl-base 5.22.1 from source, and then building pcp from source? – nn3112337 Mar 14 at 16:54
  • No, you won’t be able to revert to Perl 5.22.1 easily. Rebuilding pcp from source (using the Debian source package) will pick up the current Perl and its dependencies. I suspect you’ll need to rebuild an older pcp than the current one (to avoid the MySQL/Galera dependencies). – Stephen Kitt Mar 14 at 16:59
  • I've tried both rebuilding pcp 3.10.9 from source (newest version without the need for libpcp-pmda-perl as far as im aware) as well as building a .deb with debuild from the snaphot of 3.10.8 and i run into the same issue, which I really cant make sense of: pastebin.com/AvYWb5m9 – nn3112337 Mar 15 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.