0

Since I have upgraded kde plasma my desktop won't start showing me a blank screen with mouse cursor in tty1.

According to some searches I have tried to solve the problem with updating and upgrading using these commands:

sudo apt update
sudo apt upgrade
sudo apt dist-upgrade

I'm using kde plasma 5.15.3.

So any suggestion to solve, Thanks in advance.

1

The issue appears to affect various users (including me!), but owing to the complexity of KDE/Plasma etc. it's not an easy fix. Some people get a blank screen, and nothing more, others just have the case of the GUI session taking forever to eventually load the desktop. Rather than having to manually load your X session each time, also try the following:

  1. Try setting the permissions of ~/.config to 775 or even 777, via
    chmod g+rwx ~/.config -R
    
    for the former, a+rwx for the latter.
  2. Also try resetting the ownership of all the ~/.config files to the correct local user, as some users reported issues with files owned by root after an upgrade. Use
    chown user.user ~/.config -R
    
  3. Some users also found that removing all the KDE config files worked for them, so try:
    mkdir ~/temp
    mv ~/.kde ~/temp/.kde
    
    or if you get an error:
    mv ~/.kde* ~/temp/.kde
    
    mv ~/.cache ~/temp/.cache
    mv ~/.local ~/temp/.local
    mv ~/.config ~/temp/.config
    
    And then reboot or restart the login manager, and try again. You can then manually copy back whatever app settings you need from .config or .local to get back your personal settings. It's a pain, but it has worked for some.
  4. Also try a dist-upgrade instead of a plain upgrade (as @MohamedSlama reported in the original question!). Follow the howto for your distro... but basically it's recommended to get a terminal login and goto init 3 (kill graphical login) and then from a root screen session, issue the dist-upgrade command. Then see if it comes right.
  5. In my case, openSuse Leap 42.3 upgrade to 15.1, a dist-upgrade didn't work either. I had to move from the stable Leap 15.1 to Tumbleweed to get things going... but I did work on another machine, with the same issue, and traced the issue to the plasmashell. This has historically given me issues, and I often reset via a script that runs
    kquitapp plasmashell && kstart plasmashell &
    
1
  • 1
    #3 works very well if you have made a lot of customizations to themes, etc. and the theme has been uninstalled by upgrades. – Peter Dec 15 '20 at 8:23
0

Okay after i have searched for a long time i found a simple alternative solution.

  1. Open tty2 by clicking Ctrl + Alt + F2.
  2. Enter username.
  3. Enter password.
  4. Write command startx.
1
  • 1
    If this is the solution, then it means you have no graphical login manager installed/running after the upgrade. Also, a manual startx like this may not work as expected on modern distros. Additionally, note that this is not a solution if X is already running, but just broken... as X will refuse to start, unless you specify a different screen session. Go well. – sarlacii Dec 15 '20 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.