0

I have just installed kubuntu and as soon as I try to install new package it always show this message :

Media change: please insert the disc labeled

'Kubuntu 18.04.1 LTS Bionic Beaver - Release amd64 (20180725)' in the drive '/media/cdrom/' and press [Enter]

0

I've ran into this on Debian installs (never an Ubuntu derivative). The solution in my Debian cases is to edit (as superuser--back up the file, be careful, etc., etc.) the file /etc/apt/sources.list and comment out a line beginning with something like "deb cdrom", and add URLs for online repositories.

Okay...quick check, and you're not the only person to run into this. Here: https://vninja.net/2018/10/08/ubuntu-18.04.1-lts-bionic-beaver-sources.list/ you can find some instructions for restoring a "normal" Kubuntu sources.list file (the webpage I've linked, in turn uses this sources.list file: https://gist.githubusercontent.com/h0bbel/4b28ede18d65c3527b11b12fa36aa8d1/raw/a4ab1c13a92171822215143b1e3b3eb6add7a78d/sources.list)

  • Yes I have commented out the line , but it shows now that package build essentials is obsolete. – abdemirza Mar 14 at 5:16
  • And also after adding the repositories url , apt update returns that you cannot add repositories as this feature is disabled by default , any way to enable that ? – abdemirza Mar 14 at 5:17
  • I tried installing Kubuntu 18.04.1 in a VM to see if I could replicate your problem. The installation gave me a good sources.list, so that wasn't a problem for me, but I moved it and tried the instructions I linked to anyway. It worked on my installation. I did a minimal install and accepted all default options. If you're in a situation where you can easily reinstall, I'd recommend doing that, possibly try a more recent ISO (18.04.2 is available). – wurtzkurdle Mar 14 at 7:12
  • Please keep us up to date, by editing your question. Show us what you have done, and what happened. – ctrl-alt-delor Mar 14 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.