0

My problem is that no static IP is getting assigned to the built-in ethernet port. I have run netplan apply several times. I've also rebooted the PC and still no luck.

I am sure the ethernet port works as I was previously using it on Ubuntu 16.04 just before I decided to fresh install 18.04.2.

Any ideas what I could be doing wrong? I am going to use the ethernet port to connect my main PC to the Ubuntu server via a crossover cable.

If I set the ethernet port to use dchp4:true and connect an ethernet cable from it to my modem/router and disable my WiFi card (by removing the netplan config), the PC can connect to the net without any issues.

Thanks


This is the output of netplan --debug apply which also shows the contents of my YAML files. I have tried with and without dhcp4/dchp6/gateway4/renderer.

enter image description here

-1

I had sucess with interfaces file, like previous version. With following static ip config like eth0 in the following example.

root@redbird:~# cat /etc/network/interfaces

interfaces(5) file used by ifup(8) and ifdown(8)

auto lo iface lo inet loopback

auto eth0 iface eth0 inet static address 192.168.0.130 netmask 255.255.255.0 network 192.168.0.0 broadcast 192.168.0.255 gateway 192.168.0.1

** Broadcast and Network lines are optional **
and simply an ifup.

"ifup enp3s0" .

Is network-manager defined as renderer ?..

Disable networkd and run netplan to see if it is applying the config.

  • I first tried that but when I viewed /var/log/syslog, I got messages there that goes like "you're doing it the wrong way". This then prompted me to search the net on the way of doing network stuff on Ubuntu Bionic. – mrjayviper Mar 14 at 6:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.