0

I am running debian with systemd version 241. I have a nand flash ubifs partition for my rootfs that I have split into two volumes (/dev/ubi0_1 for rootfs and /dev/ubi0_2 for var):

ubi0:rootfs on / type ubifs (ro,relatime,assert=read-only,ubi=0,vol=1)
/dev/ubi0_2 on /var type ubifs (rw,relatime,assert=read-only,ubi=0,vol=2)

systemd-timesyncd gives me the following error on boot:

[FAILED] Failed to start Network Time Synchronization.
See 'systemctl status systemd-timesyncd.service' for details.

journalctl gives the following:

Mar 13 22:46:45 nelson systemd[1]: Stopped Network Time Synchronization.
Mar 13 22:46:45 nelson systemd[1]: systemd-timesyncd.service: Failed to run 'start' task: Read-only file system
Mar 13 22:46:45 nelson systemd[1]: systemd-timesyncd.service: Failed with result 'resources'.

If I switch the rootfs to rw then the error goes away.

Here is the output of ls -l /var/lib/systemd/timesync/clock:

-rw-r--r-- 1 systemd-timesync systemd-timesync 0 Mar 13 21:09 /var/lib/systemd/timesync/clock

I also see a similar issue with systemd-resolved.

0

Turns out that in my build (Debian Buster) that /tmp was not being set as a tmpfs automatically. So I turned on the tmp mount in systemd as follows:

cp /usr/share/systemd/tmp.mount /etc/systemd/system/
systemctl enable tmp.mount

Both journalctl and resolved require write access to /tmp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.