2

I am using debian installer together with a preseed config-file to automate installation steps.

Currently the network-card selection still shows up and I cannot find out why.

I have the following networking-related lines

d-i netcfg/choose_interface select auto
d-i netcfg/choose_interface select enp0s8
d-i netcfg/link_wait_timeout string 20

The selected interface-card is available in the dialog that appears and also when installation finishes:

$ sudo ifconfig
enp0s8: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
...

However the Debian installer still stops and forces me to choose the network-card to use.

How do adjust the preseed file to also perform this selection automatically?

2

Ugh, warming up old stuff. But I just had the same problem and found the solution.

The issue is that the preseed file is loaded after the d-i performs network configuration (sic!). So when you get to the interface selection, the preseed anwsers are yet unknown.

So you need to add the relevant interface to the kernel commandline like so:

auto=true priority=critical interface=enp0s8 url=http://host/path/to/preseed.cfg

interface is an alias for netcfg/choose_interface and you can thus (and should) remove all netcfg/ entries from preseed file.

| improve this answer | |
0

The only option that I found was to remove all but one network interfaces of the VirtualBox machine, then the installer seems to automatically select this one.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.