1

I installed Debian for a server purpose and I do not need a good quality text mode. I would like to keep the very rough bad resolution text mode that is appearing just after a grub choice screen. Just going to get a minimal system.

How to achieve it?

Update

I am being getting many questions what the question actually mean. So please watch the yt link https://youtu.be/cTK3aIZbe2A?t=39

You can see a text

[blabla,blabla]kvm: disabled by bios
[blabla,blabla]kvm: disabled by bios

It is displayed in a bad small, resolution. Isn't it? But in some milliseconds the text and lines upon it are changing to the better resolution! It happens in about one second but you can see it.

My question is how to avoid this resolution change and keep initial bad resolution

Update 2

I am not sure that my aim is clear so I prepared an image that may help. On the image one can see two text modes of a screen during Debian initialization. The upper is more rough and the lower is more elegant. The upper is earlier then the lower. I want to keep this rough one and prevent the system from changing it during boo time. So after the boot time it is still like this upper one.

enter image description here

  • 1
    What’s wrong with the higher-resolution text mode you presumably end up with? – Stephen Kitt Mar 13 at 18:51
  • 1
    The question needs to state which platform this is, and how you think that just changing KVTs between two text modes makes any difference to the size of the system. – JdeBP Mar 13 at 18:52
  • @StephenKitt I dont't know. The question is how to get rid of it. – trzczy Mar 13 at 23:01
  • @JdeBP What do you mean platform? I need pure rough text mode. The higher resolution is useless improvement. – trzczy Mar 13 at 23:04
  • 1
    Is the advice listed here and here what you are trying to do? Most people try to increase the font resolution and screen resolution of the boot screen for a sharper image. It is no wonder you found no advice or tutorial in reverse. – kemotep Mar 15 at 20:57
1

To achieve this you need to disable modesetting. Edit /etc/default/grub to add

nomodeset i915.modeset=0 nouveau.modeset=0

to the GRUB_CMDLINE_LINUX_DEFAULT line, then run

update-grub
update-initramfs -u

as root, and reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.