0

I tried to turn off the tcp timestamp but it didn't work. The step i performed are the following:

$ sysctl -w net.ipv4.tcp_timestamps=0
$ sysctl -p
$ sysctl net.ipv4.tcp_timestamps (=> to be sure that it has been set to 0)
$ hping3 www.google.com -S -c 1 -p 443 --tcp-timestamp

and i obtained:

TCP timestamp: tcpts=2513557362

I also tried to sniff the traffic through wireshark and i saw that every tcp packet contains the value in the timestamps field.

I'm using Linux Debian 4.9.13.

What I'm doing wrong?

0

hping3 don't care about 'sysctl net.ipv4.tcp_timestamps', that's why it have '--tcp-timestamp' option.
Try to use curl (for example), you should see difference.

New contributor
Evgeny is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.