-1

Take a look at all openconnect versions & this.

What is the correct way to install openconnect(ocserv-0.12.3) package on CentOs 7?

I tried these commands :

sudo yum -y install epel-release
sudo yum repolist enabled
sudo yum info ocserv

But it shows me version 0.12.2, not version 0.12.3!
Now how can i install version 0.12.3?

2

As version 0.12.3 is EPEL candidate you can install it via downloading the package (RPM) and install it. Or compile it from source. But I will recommend you to install available in EPEL package and do not hurry up. The command you can use is:

wget https://kojipkgs.fedoraproject.org//packages/ocserv/0.12.3/1.el7/x86_64/ocserv-0.12.3-1.el7.x86_64.rpm
yum localinstall ocserv-0.12.3-1.el7.x86_64.rpm

OF course you can install it directly via rpm but this will bring warning messages later when you use again yum

rpm -i wget https://kojipkgs.fedoraproject.org//packages/ocserv/0.12.3/1.el7/x86_64/ocserv-0.12.3-1.el7.x86_64.rpm
  • Thanks, teach me how did you find that rpm? – SilverLight Mar 13 at 6:03
  • @SilverLight, check you second link. And you will see RPM's there (for different platforms) And for each there is download link – Romeo Ninov Mar 13 at 6:08
  • 1
    Thanks man / I installed it like a charm... – SilverLight Mar 13 at 6:12
  • @SilverLight, in such case feel free to accept my answer :) – Romeo Ninov Mar 13 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.