1

I want to upgrade my version of ubuntu from 14.04 LTS to the latest. First, I have to update from Ubuntu 14.04 LTS to 16 LTS, but when I try to upgrade my system I've got these errors:

W:Imposible to get http://archive.ubuntu.com/ubuntu/dists/stable/main/binary-amd64/Packages  404  Not Found 
, W:Imposible to get http://archive.ubuntu.com/ubuntu/dists/stable/main/binary-i386/Packages  404  Not Found 
, E:It has been impossible to download some index files or have been ommited or have been used other olders.

My source.list is:

###### Ubuntu Main Repos
deb http://es.old-releases.ubuntu.com/ubuntu/ trusty main restricted universe multiverse 
deb-src http://es.old-releases.ubuntu.com/ubuntu/ trusty main restricted universe multiverse 

###### Ubuntu Update Repos
deb http://es.old-releases.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse 
deb http://es.old-releases.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse 
deb-src http://es.old-releases.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse 
deb-src http://es.old-releases.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse 

###### Ubuntu Partner Repo
deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner

###### Ubuntu Extras Repo
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main

How can I update from ubuntu 14.04 LTS to Ubuntu 16 LTS without errors? What am I doing wrong?

EDIT I:

How trusty version is still supported I have changed my sources.list but I've got still get the same error :(

sources.list

###### Ubuntu Main Repos
deb http://es.ubuntu.com/ubuntu/ trusty main restricted universe multiverse 
deb-src http://es.ubuntu.com/ubuntu/ trusty main restricted universe multiverse 

###### Ubuntu Update Repos
deb http://es.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse 
deb http://es.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse 
deb-src http://es.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse 
deb-src http://es.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse 

###### Ubuntu Partner Repo
deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner

###### Ubuntu Extras Repo
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main

I don't know what happend :(

EDIT II:

In my /etc/apt/sources.list.d folder I've got these files:

enter image description here

EDIT III:

I have followed the tips of @Kulfy and it doesn't work. Here is my screen caps with the state of my settings:

enter image description here

The system gave me like best server: http://la-mirrors.evowise.com/ubuntu

enter image description here

What I've got in my update tab is:

enter image description here

And I've got this new error. It says that the error maybe caused by:

  • Try to update to an Ubuntu version not published yet.
  • To be executing the actual version and not published yet.
  • Unofficial software packages not provided by Ubutu

If none of this applies, report this error using the command "ubuntu-bug ubuntu-release-upgrader-core" in a terminal.

Is there any solution to my problem? :(

enter image description here

Edit IV:

During the process of upgrading in the console I've got this exit:

  Hold prevents MarkGarbage of php5-common [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-readline [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-cli [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-json [ amd64 ] < 1.3.2-2build1 > ( php )
  Hold prevents MarkGarbage of php-gettext [ amd64 ] < 1.0.11-1 > ( universe/web )
  Hold prevents MarkGarbage of php5-gd [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-common [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-readline [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-cli [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-json [ amd64 ] < 1.3.2-2build1 > ( php )
  Hold prevents MarkGarbage of php-gettext [ amd64 ] < 1.0.11-1 > ( universe/web )
  Hold prevents MarkGarbage of php5-gd [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-common [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-readline [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-cli [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-json [ amd64 ] < 1.3.2-2build1 > ( php )
  Hold prevents MarkGarbage of php-gettext [ amd64 ] < 1.0.11-1 -> 1.0.11-2build1 > ( universe/web )
  Hold prevents MarkGarbage of php5-gd [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-common [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-readline [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-cli [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-json [ amd64 ] < 1.3.2-2build1 > ( php )
  Hold prevents MarkGarbage of php-gettext [ amd64 ] < 1.0.11-1 -> 1.0.11-2build1 > ( universe/web )
  Hold prevents MarkGarbage of php5-gd [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-common [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-readline [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-cli [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-json [ amd64 ] < 1.3.2-2build1 > ( php )
  Hold prevents MarkGarbage of php-gettext [ amd64 ] < 1.0.11-1 > ( universe/web )
  Hold prevents MarkGarbage of php5-gd [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-common [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-readline [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-cli [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )
  Hold prevents MarkGarbage of php5-json [ amd64 ] < 1.3.2-2build1 > ( php )
  Hold prevents MarkGarbage of php-gettext [ amd64 ] < 1.0.11-1 > ( universe/web )
  Hold prevents MarkGarbage of php5-gd [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( php )

The last lines of the command grep Broken /var/log/dist-upgrade/apt.log are:

Broken rhythmbox-plugins:amd64 Depende on rhythmbox [ amd64 ] < 3.0.2-0ubuntu2 -> 3.3-1ubuntu7 > ( gnome ) (= 3.3-1ubuntu7)
Broken gnome-session:amd64 Depende on gnome-settings-daemon [ amd64 ] < 3.8.6.1-0ubuntu11.2 -> 3.18.2-0ubuntu3 > ( universe/gnome ) (>= 3.0)
Broken rhythmbox-plugin-zeitgeist:amd64 Depende on rhythmbox [ amd64 ] < 3.0.2-0ubuntu2 -> 3.3-1ubuntu7 > ( gnome ) (>= 3.3-1ubuntu7)
Broken python3-checkbox-ng:amd64 Depende on python3-checkbox-support [ amd64 ] < 0.2-1 -> 0.22-1 > ( python ) (>= 0.22)
Broken plainbox-provider-resource-generic:amd64 Depende on python3-checkbox-support [ amd64 ] < 0.2-1 -> 0.22-1 > ( python ) (>= 0.2)
Broken plainbox-provider-checkbox:amd64 Depende on plainbox-provider-resource-generic [ amd64 ] < 0.3-1 -> 0.23-1 > ( utils ) (>= 0.3)
Broken session-shortcuts:amd64 Depende on gnome-session-bin [ amd64 ] < 3.9.90-0ubuntu12.1 -> 3.18.1.2-1ubuntu1 > ( gnome )
Broken oneconf:amd64 Depende on python3-oneconf [ amd64 ] < 0.3.7.14.04.1 -> 0.3.9 > ( universe/python )
Broken gnome-shell:amd64 Depende on gnome-session [ amd64 ] < 3.9.90-0ubuntu12.1 -> 3.18.1.2-1ubuntu1 > ( universe/gnome )
Broken checkbox-converged:amd64 Depende on plainbox-provider-checkbox [ amd64 ] < 0.4-1 -> 0.25-1 > ( utils )
Broken deja-dup-backend-gvfs:amd64 Depende on gvfs-backends [ amd64 ] < 1.20.3-0ubuntu1.2 -> 1.28.1-1ubuntu1 > ( libs )
Broken ubuntu-software:amd64 Depende on gnome-software [ amd64 ] < none -> 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2 > ( gnome ) (= 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2)
Broken rhythmbox-plugin-magnatune:amd64 Depende on rhythmbox [ amd64 ] < 3.0.2-0ubuntu2 -> 3.3-1ubuntu7 > ( gnome ) (= 3.3-1ubuntu7)
Broken rhythmbox-mozilla:amd64 Depende on rhythmbox [ amd64 ] < 3.0.2-0ubuntu2 -> 3.3-1ubuntu7 > ( gnome ) (= 3.3-1ubuntu7)
Broken rhythmbox-plugin-cdrecorder:amd64 Depende on rhythmbox [ amd64 ] < 3.0.2-0ubuntu2 -> 3.3-1ubuntu7 > ( gnome ) (= 3.3-1ubuntu7)
Broken php5:amd64 Depende on libapache2-mod-php5 [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( httpd ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken php5:amd64 Depende on libapache2-mod-php5filter [ amd64 ] < none > ( none ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken php5:amd64 Depende on php5-cgi [ amd64 ] < none > ( none ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken php5:amd64 Depende on php5-fpm [ amd64 ] < none > ( none ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken dpkg:amd64 Rompe on ureadahead [ amd64 ] < 0.100.0-16 -> 0.100.0-19 > ( admin ) (< 0.100.0-17~)
Broken init:amd64 PreDepende on systemd-sysv [ amd64 ] < none -> 229-4ubuntu4 > ( admin )
Broken init:amd64 PreDepende on upstart-sysv [ amd64 ] < none -> 1.13.2-0ubuntu21 > ( admin )
Broken policykit-1:amd64 Depende on libpam-systemd [ amd64 ] < 204-5ubuntu20.29 -> 229-4ubuntu4 > ( admin )
Broken libpam-systemd:amd64 Depende on systemd-services [ amd64 ] < 204-5ubuntu20.29 > ( admin ) (= 204-5ubuntu20.29)
Broken gvfs:amd64 Depende on gvfs-daemons [ amd64 ] < 1.20.3-0ubuntu1.2 -> 1.28.1-1ubuntu1 > ( libs ) (>= 1.28.1-1ubuntu1)
Broken cron:amd64 Depende on upstart-job [ amd64 ] < none > ( none )
Broken avahi-daemon:amd64 Depende on upstart [ amd64 ] < 1.12.1-0ubuntu4.2 -> 1.13.2-0ubuntu21 > ( admin ) (>= 0.6.7-4)
Broken libnss-mdns:amd64 Depende on avahi-daemon [ amd64 ] < 0.6.31-4ubuntu1.3 -> 0.6.32~rc+dfsg-1ubuntu2 > ( net ) (>= 0.6.16-1)
Broken ureadahead:amd64 Depende on init-system-helpers [ amd64 ] < 1.14ubuntu1 -> 1.29ubuntu1 > ( admin ) (>= 1.18~)
Broken systemd-services:amd64 Depende on udev [ amd64 ] < 204-5ubuntu20.29 -> 229-4ubuntu4 > ( admin ) (>= 175-0ubuntu23)
Broken nautilus:amd64 Depende on gvfs [ amd64 ] < 1.20.3-0ubuntu1.2 -> 1.28.1-1ubuntu1 > ( libs ) (>= 1.3.2)
Broken telepathy-salut:amd64 Depende on avahi-daemon [ amd64 ] < 0.6.31-4ubuntu1.3 -> 0.6.32~rc+dfsg-1ubuntu2 > ( net )
Broken nautilus-sendto:amd64 Depende on nautilus [ amd64 ] < 1:3.10.1-0ubuntu9.11 -> 1:3.18.4.is.3.14.3-0ubuntu4 > ( gnome ) (>= 1:2.91)
Broken checkbox-ng:amd64 Depende on python3-checkbox-ng [ amd64 ] < 0.3-2 -> 0.23-2 > ( utils ) (= 0.23-2)
Broken checkbox-gui:amd64 Depende on checkbox-converged [ amd64 ] < none -> 1.2.4-0ubuntu1 > ( oldlibs )
Broken gvfs-fuse:amd64 Depende on gvfs [ amd64 ] < 1.20.3-0ubuntu1.2 -> 1.28.1-1ubuntu1 > ( libs ) (= 1.28.1-1ubuntu1)
Broken avahi-utils:amd64 Depende on avahi-daemon [ amd64 ] < 0.6.31-4ubuntu1.3 -> 0.6.32~rc+dfsg-1ubuntu2 > ( net )
Broken brasero:amd64 Depende on gvfs [ amd64 ] < 1.20.3-0ubuntu1.2 -> 1.28.1-1ubuntu1 > ( libs )
Broken php5:amd64 Depende on libapache2-mod-php5 [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( httpd ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken php5:amd64 Depende on libapache2-mod-php5filter [ amd64 ] < none > ( none ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken php5:amd64 Depende on php5-cgi [ amd64 ] < none > ( none ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken php5:amd64 Depende on php5-fpm [ amd64 ] < none > ( none ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken libpam-systemd:amd64 Depende on systemd-services [ amd64 ] < 204-5ubuntu20.29 > ( admin ) (= 204-5ubuntu20.29)
Broken account-plugin-salut:amd64 Depende on telepathy-salut [ amd64 ] < 0.8.1-1ubuntu3 -> 0.8.1-5ubuntu1 > ( universe/net )
Broken php5:amd64 Depende on libapache2-mod-php5 [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( httpd ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken php5:amd64 Depende on libapache2-mod-php5filter [ amd64 ] < none > ( none ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken php5:amd64 Depende on php5-cgi [ amd64 ] < none > ( none ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken php5:amd64 Depende on php5-fpm [ amd64 ] < none > ( none ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken policykit-1:amd64 Depende on libpam-systemd [ amd64 ] < 204-5ubuntu20.29 -> 229-4ubuntu4 > ( admin )
Broken policykit-1-gnome:amd64 Depende on policykit-1 [ amd64 ] < 0.105-4ubuntu3.14.04.5 -> 0.105-14.1 > ( admin )
Broken colord:amd64 Depende on policykit-1 [ amd64 ] < 0.105-4ubuntu3.14.04.5 -> 0.105-14.1 > ( admin ) (>= 0.103)
Broken ubuntu-system-service:amd64 Depende on policykit-1 [ amd64 ] < 0.105-4ubuntu3.14.04.5 -> 0.105-14.1 > ( admin )
Broken gnome-system-log:amd64 Depende on policykit-1 [ amd64 ] < 0.105-4ubuntu3.14.04.5 -> 0.105-14.1 > ( admin )
Broken python3-plainbox:amd64 Depende on policykit-1 [ amd64 ] < 0.105-4ubuntu3.14.04.5 -> 0.105-14.1 > ( admin )
Broken landscape-client-ui-install:amd64 Depende on policykit-1 [ amd64 ] < 0.105-4ubuntu3.14.04.5 -> 0.105-14.1 > ( admin )
Broken php5:amd64 Depende on libapache2-mod-php5 [ amd64 ] < 5.5.9+dfsg-1ubuntu4.16 > ( httpd ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken php5:amd64 Depende on libapache2-mod-php5filter [ amd64 ] < none > ( none ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken php5:amd64 Depende on php5-cgi [ amd64 ] < none > ( none ) (>= 5.5.9+dfsg-1ubuntu4.16)
Broken php5:amd64 Depende on php5-fpm [ amd64 ] < none > ( none ) (>= 5.5.9+dfsg-1ubuntu4.16)
  • I suggest to try different server. – Pandya Mar 11 at 12:30
  • Hi @Kulfy!!! Thanks for your help!! I have changed my sources.list but I've got the same error :( I have modified my original post. – José Carlos Mar 11 at 13:01
  • Yes!!! I have updated my original post with the content of this folder @Kulfy – José Carlos Mar 11 at 15:07
  • Thank you for your help!!! But now, I've got another different error :( I'm going to update my original post. – José Carlos Mar 11 at 15:56
  • I have update my original post @Kulfy – José Carlos Mar 11 at 16:36
2

Trusty Tahr (Ubuntu 14.04) is supported till April '19. Its repository isn't migrated to old-releases yet. Moreover, there is no URL like http://es.old-releases.ubuntu.com/ (at least I can't connect to it from a browser).

Since you want to do a release upgrade, 3rd party repositories (which can also be found in /etc/apt/sources.list.d/ folder) must be disabled.

You need to either restore your repository information (sources.list) to default and disable 3rd party repositories. For this, you can use the easiest method, GUI method.

  • Open Software and Updates app.
  • Select the Updates you want to receive (main, universe, multiverse, restricted).
  • Disable third party repositories from Other software tab.

If you want to achieve it using CLI method (preferably for servers):

  • To restore default repositories, run,

    echo "deb http://archive.ubuntu.com/ubuntu trusty main universe restricted multiverse" |  sudo tee /etc/apt/sources.list > /dev/null
    
  • To disable third party repositories, run,

    sudo sed -i 's/^/#/' /etc/apt/sources.list.d/*
    

Now you got an error like:

  • Try to update to an Ubuntu version not published yet.
  • To be executing the actual version and not published yet.
  • Unofficial software packages not provided by Ubuntu

These errors are generally due to some contradiction in package versions which are mostly installed from 3rd party repository. The upgrade will break the packages or vice versa, so upgrade isn't attempted. Disabling 3rd party repository as well as removing packages installed from those repositories should be done to get the upgrade successful.

Here, you had php5 installed from a 3rd party repository. Remove that using:

sudo apt remove php5

Try upgrade again:

sudo apt update
sudo apt upgrade
sudo do-release-upgrade
0

Comments suggest that your issue has already been solved but here are some additional hints for future readers that may hit the same problem.

The error messages you got were

W:Imposible to get http://archive.ubuntu.com/ubuntu/dists/stable/main/binary-amd64/Packages  404  Not Found 
, W:Imposible to get http://archive.ubuntu.com/ubuntu/dists/stable/main/binary-i386/Packages  404  Not Found 
, E:It has been impossible to download some index files or have been ommited or have been used other olders.

and the important part is http:​//archive.ubuntu.com/ubuntu/dists/stable/main/... where the part that you have word stable should be one of the release names of Ubuntu. You can browse http://archive.ubuntu.com/ubuntu/dists/ for possible choices but in this case, it should probably be trusty instead of stable.

Codenames such as stable or unstable are used by Debian but not by Ubuntu. I guess you have accidentally added some Debian repositories to your Ubuntu system (which is possible to do and in some cases you might even want to do that but the fact that you didn't understand the error messages above suggests that you didn't have this on purpose).

The repositories that the system uses are kept in file /etc/apt/sources.list and inside directory /etc/apt/sources.list.d. To find out which file contains the incorrect source definition you can do following in the terminal:

grep -nri stable /etc/apt/sources.list.d /etc/apt/sources.list

Once you find the file and line number of the problematic repository source, you can either fix the repository address or remove/disable the repository. Disabling the repository can be done by adding `# " at the start of the line that roughly looks like

deb http://archive.canonical.com/ubuntu stable main

After disabling this repository, the line should look like this instead:

# deb http://archive.canonical.com/ubuntu stable main

After saving the file you can do

sudo apt-get update

without errors.

  • Thank you for your answer @Mikko Rantalainen!!! – José Carlos Mar 12 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.