2

I am running Kali Linux 2019 with Gnome 3.30.2 on a somewhat older Lenovo ThinkPad s540 and I am really enjoying modern Gnome. I do have a problem though;

I'm located in the Netherlands, so the keyboard layout that is common over here is US International with Dead Keys. In /etc/default/keyboard:

XKBLAYOUT=us
XKBVARIANT=intl
BACKSPACE=guess

I have also made sure that the right keyboard layout is set in Gnome Settings. For this, I had to add English (US, intl with Dead Keys).

Which is perfectly fine. I can use my keyboard layout throughout a Gnome session and dead keys are functioning as well. i.e. <Shift+6>,<U> results in Û. The problem comes around when I start the laptop and I get the Gnome login screen.

Dead keys are not recognized at all in there, they do not even work as regular keys. <Shift+6> results in nothing (either when followed by a space or supported character yields no output).

I have been trying to look for ways to enable dead keys in the login screen, however I found no results. All accessibility options are turned off with the exception of the On-Screen keyboard so that I am able to 'type' the special characters through that.

How can I enable dead keys in gnome-login?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.