21

After ssh without -X to a machine, is it possible to change some settings (for example $DISPLAY) to make it work like ssh -X? If not, what is the reason? Thanks.

30

You can create a second connection with X11 forwarding enabled, and then you can also use the DISPLAY environment variable from the second connection in the first.

In the 1st window:

$ ssh user@host
user@host$ ...

In the 2nd window:

$ ssh -Y user@host 'echo $DISPLAY; while sleep 3600; do :; done'
localhost:10.0

Back to the 1st window:

user@host$ export DISPLAY=localhost:10.0
user@host$ xterm

Unfortunately, ssh does nothing to contain the X11 (or other) forwardings to the process/session it started or to the user it runs as on the remote machine (eg. by using Unix sockets with/out checking credentials, or by using namespaces), and those forwardings are simple tcp listening sockets to which anybody on the remote machine can connect; all the security of the X11 forwarding relies on the X11 authentication.

X11 Forwarding By Hand

The sshd_config(5) manpage mentions that:

disabling X11 forwarding does not prevent users from forwarding X11 traffic, as users can always install their own forwarders.

Here is how you can do that by hand.

Show the auth info for DISPLAY=:0 on the local machine:

$ xauth list :0
ohzd/unix:0  MIT-MAGIC-COOKIE-1  a86982ddce0c1e1c1a8c5e8b2846e43b

Connect to the remote machine without any X11 forwarding:

$ ssh user@hzy64
user@hzy64's password:
[motd snipped]

Open the command line via ~C and add a remote forwarding from the port 6000+43 to the unix socket corresponding to display :0:

hzy64$~C
ssh> -R 6043:/tmp/.X11-unix/X0
Forwarding port.

Set the $DISPLAY envvar and add the auth info from the local to the remote machine:

hzy64$ export DISPLAY=localhost:43
hzy64$ xauth add $DISPLAY . a86982ddce0c1e1c1a8c5e8b2846e43b
xauth:  file /home/user/.Xauthority does not exist

Now you're ready to go:

hzy64$ xterm
  • If you care about security, -X would be slightly better than -Y, wouldn’t it? – Stephen Kitt Mar 10 at 17:22
  • 8
    many (most?) X11 programs don't work with -X, only with -Y. people don't notice that because on many system (eg. debian) ForwardX11Trusted is set to yes by default, and the -X and -Y options are equivalent ;-) – mosvy Mar 10 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.