2

I have built a server on Debian Stretch. It has three ethernet cards and one wifi card Gemtek WPIA-116G.

When a cable is connected it works well. But without the cable, by wifi, a client computer gets a connection but does not open some sites in browsers. The same on my tablet.

So it opens google.com and wikipedia but does not open github and testmy.net.

When it tries to open github or testmy.net such an info is displayed at the bottom of a browser Establishing secure connection... and it is in stack.

Here you are my config:

root@ruter-adam:/home/s# cat /etc/hostapd/hostapd.conf
interface=wlp2s5
bridge=br0
driver=nl80211
logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=2
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
ssid=abcabc
country_code=PL
ieee80211d=1
hw_mode=g
channel=8
beacon_int=100
dtim_period=2
max_num_sta=255
rts_threshold=2347
fragm_threshold=2346
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wmm_enabled=1
wmm_ac_bk_cwmin=4
wmm_ac_bk_cwmax=10
wmm_ac_bk_aifs=7
wmm_ac_bk_txop_limit=0
wmm_ac_bk_acm=0
wmm_ac_be_aifs=3
wmm_ac_be_cwmin=4
wmm_ac_be_cwmax=10
wmm_ac_be_txop_limit=0
wmm_ac_be_acm=0
wmm_ac_vi_aifs=2
wmm_ac_vi_cwmin=3
wmm_ac_vi_cwmax=4
wmm_ac_vi_txop_limit=94
wmm_ac_vi_acm=0
wmm_ac_vo_aifs=2
wmm_ac_vo_cwmin=2
wmm_ac_vo_cwmax=3
wmm_ac_vo_txop_limit=47
wmm_ac_vo_acm=0
ap_max_inactivity=600
#ieee80211n=1
require_ht=0
eapol_version=2
eapol_key_index_workaround=0
eap_server=0
own_ip_addr=127.0.0.1
wpa=2
wpa_psk=6d68b63bdc2dff68cbe7cee4aa104882e8e40123456789ef35069ad2edf81579
wpa_key_mgmt=WPA-PSK WPA-PSK-SHA256
wpa_pairwise=CCMP
rsn_pairwise=CCMP
wpa_group_rekey=600
wpa_gmk_rekey=21600
peerkey=1
wps_state=0

root@ruter-adam:/home/s# 

root@ruter-adam:/home/s# cat /etc/wpa_supplicant/wpa_supplicant.conf 
network={
    id_str="home_wifi_static"
    priority=5
    ssid="abcabc"
    psk=363686d31b1fda24ef42b86401234567890faa3f35df2f8ad04a7884213e7916
    proto=RSN
    key_mgmt=WPA-PSK-SHA256
    pairwise=CCMP
    group=CCMP
    auth_alg=OPEN
    scan_ssid=0
    disabled=0
}
root@ruter-adam:/home/s# 

How to fix it?

Update

I did some MTU and ping experiences to state if it a difference between when LAN is connected or WLAN. And the issue is with the WLAN connection the MTU value is not less then with LAN. In both directions and with both connection types (LAN/WLAN) it was 1472.

The commands:

ping -M do -c 4 -s 1472 192.168.0.1 #client
ping -M do -c 4 -s 1472 192.168.0.2 #server

Update 2

The experiences with 1300 has another issue:

With the cable, in both directions, it was 0% packet loss

And via WIFI, it was 100% and 75% and 50% packet loss during several tests, from the client to the server.

And via WIFI it was 100% packet loss during several tests, from the server to the client.

  • 1
    does it work with rts_threshold=-1 and fragm_threshold=-1 , both at the same time? I suspect you are having MTU issues, but that should be a clue some configuration is not ok at lower level. Does that WiFi configuration work well with that chipset when connecting as a client to an ac router? – Rui F Ribeiro Mar 10 at 4:06
  • Changing boths values to -1 causes errors of invalid value. Maybe I do not understand the second question... My router is a computer with debian and it has eth and wlan cards. Isn't it "an ac router"? The configuration of course doesn't work ok as I have described. I also did some experiences with MTU and ping. You may look at an update to the question. – trzczy Mar 10 at 12:55
  • Try them to 1300 also. I was asking if you have already used that WiFi card connecting to an ac router successfully – Rui F Ribeiro Mar 10 at 12:58
  • I updated the question with 1300 MTU pings. No I haven't used it to connect to the ac router. – trzczy Mar 10 at 18:11
  • I must be missing something, but it looks you are using the same WiFi card of your server both as an AP (with hostapd) and as a client (with wpa-supplicant)… Is that right? What’s the point? I wouldn’t be surprised that it does not work fine… – user2233709 Mar 10 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.