0

I am currently trying to install and old version of Pango. I tried two versions, 10.5 and 1.1.1 and they say similar things. Pango 1.1.1 says:

I tried to run configure in two different versions of Pango, passing two different versions of FreeType to the configure with this command:

./configure PKG_CONFIG_PATH=/media/34GB/Arquivos-de-Programas-Linux/Freetype-2.2.1/lib/pkgconfig/

./configure PKG_CONFIG_PATH=/media/34GB/Arquivos-de-Programas-Linux/Freetype-2.9.1/lib/pkgconfig/

The results is the same for both:

checking for X... no
configure: WARNING: X development    libraries not found
checking for freetype-config... no
checking freetype/internal/tterrors.h usability... no
checking freetype/internal/tterrors.h presence... no
checking for freetype/internal/tterrors.h... no
checking for FT_Get_First_Char... no
checking for pkg-config... /usr/bin/pkg-config
checking for fontconfig >= 1.0.1...  checking for xft >= 2.0.0... configure: error: *** Didn't find any of FreeType, X11, or Win32.
*** Must have at least one backend to build 

Pango 1.05 repeats the messages until FT_Get_First_Char and then says:

configure: error: *** Didn't find any of FreeType, X11, or Win32.
*** Must have at least one backend to build Pango.

All I want to know is what packages I need to be able to compile Pango and where to find them.

I am running Ubuntu 10.04. I do not want to use any precompiled package, already built many other dependencies from the source and want to finish it from source packages, especially because I intend in the future to run the software that needs Pango in other distros.

The software that will need Pango only needs an old version, so I will not use a newer version, unless I have to (i.e. I cannot compile an older version). In last case, I may look for a pango dev package for my distro, but only as a last resource, if I cannot compile an old or even a newer version.

So, anyone has an idea of what packages I do need and where to find them?

  • 1
    you're not telling what OS/distro you're using; please add that info to your question. If you're on something debian-like, you should at least apt get install xorg-dev libfreetype6-dev. – mosvy Mar 9 at 21:29
  • @mosvy I am running Ubuntu 10.04. I already built many other required dependencies from source, want to finish this doing everything from source, especially because I may will want to run the software that indirectly needs Pango in the future in another distributions. – user2752471 Mar 11 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.