0

On my Xubuntu Core 18.04, I need to triple tap every time I want to open a file or folder in Thunar or other applications' (libreoffice, abiword, notepadqq, etc.) menus.

Double tap does nothing. The problem occurs w/ my Logitech K400 Professional keyboard/touchpad only.

Any fix/workaround suggestions? Should I change some of the following options? Is there an option to enable double tapping?

rf@x4580:~$ xinput list-props 10
Device 'Logitech K400 Pro':
    Device Enabled (143):   1
    Coordinate Transformation Matrix (145): 2.000000, 0.000000, 0.000000, 0.000000, 4.000000, 0.000000, 0.000000, 0.000000, 2.000000
    libinput Natural Scrolling Enabled (280):   0
    libinput Natural Scrolling Enabled Default (281):   0
    libinput Scroll Methods Available (282):    0, 0, 1
    libinput Scroll Method Enabled (283):   0, 0, 0
    libinput Scroll Method Enabled Default (284):   0, 0, 0
    libinput Button Scrolling Button (285): 2
    libinput Button Scrolling Button Default (286): 2
    libinput Middle Emulation Enabled (287):    0
    libinput Middle Emulation Enabled Default (288):    0
    libinput Accel Speed (289): 1.000000
    libinput Accel Speed Default (290): 0.000000
    libinput Accel Profiles Available (291):    1, 1
    libinput Accel Profile Enabled (292):   0, 0
    libinput Accel Profile Enabled Default (293):   1, 0
    libinput Left Handed Enabled (294): 0
    libinput Left Handed Enabled Default (295): 0
    libinput Send Events Modes Available (265): 1, 0
    libinput Send Events Mode Enabled (266):    0, 0
    libinput Send Events Mode Enabled Default (267):    0, 0
    Device Node (268):  "/dev/input/event6"
    Device Product ID (269):    1133, 16488
    libinput Drag Lock Buttons (296):   <no items>
    libinput Horizontal Scroll Enabled (297):   1

rf@x4580:~$ cat /usr/share/X11/xorg.conf.d/40-libinput.conf
# Match on all types of devices but joysticks
Section "InputClass"
        Identifier "libinput pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

EDIT: After checking libinput's man page, I added the line

Option "Tapping" "1"

to /usr/share/X11/xorg.conf.d/40-libinput.conf immediately after the first Driver "libinput" line and logged out/in. This didn't seem to affect anything, as didn't Option "Tapping" "0"

0

Seemingly a libinput bug. Must patch and rebuild libinput

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.