0

I am currently a newer user of terminal in Ubuntu. I was trying to demonstrate some features of targets in systemd. Each time that I do systemctl enable or systemctl isolate , I enter my credentials, and then it shows a blank screen with a cursor but nothing responds. Really what I'm just trying to run is multi-user mode console without the GUI. When I reboot it goes back into the GUI.

My question: Is there some other changes that I need to make before I can switch between different interfaces? Everything is standard and running on VMWare

  • If you want the target to be changed after reboot, you need systemctl set-default I think e.g. systemctl set-default multi-user.target – steeldriver Mar 8 at 1:07
  • So do systemctl commands only apply after reboots or can I change interfaces "on the fly" like init runlevel commands? – Cody Tapp Mar 8 at 1:40
  • You should be able to use systemctl isolate on-the-fly - however if you are doing it from inside a graphical desktop, the underlying virtual terminal may be messed up - not sure it's possible inside a VMWare environment but have you tried switching to a different VT (using Ctrl-Alt-F2 for example)? – steeldriver Mar 8 at 1:46
  • I tried ctrl+alt+f2 but that doesn't work. You are definitely correct, I think it must be the VM. When I set multi-user by default and ran init 6, it went into the terminal environment just fine. This will work for me as I only need it for demonstration purposes for a college presentation. This is definitely good to know for users of VM that need to switch targets. Thanks for the help. – Cody Tapp Mar 8 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.