0

I ran a fresh Minimal install of Cent OS 7. When finished, I run this command to get the GUI setup:

yum -y install epel-release;yum update -y;yum groupinstall "Xfce" -y;yum -y groupinstall X11;echo "exec /usr/bin/xfce4-session" >> ~/.xinitrc;sudo systemctl set-default graphical.target;systemctl isolate graphical.target;yum -y install sddm; systemctl stop gdm.service; systemctl disable gdm.service; systemctl enable sddm.service

Reboot, Login, SDDM is really finicky. At first I can click on a xfce4 launcher to launch terminal, after that I can't drag/resize the window with the mouse, I can't close/maximize/minimize with the mouse. I think the problem has to do with what window is in focus. For example, if I click in the black space of the terminal window, Now I can only click inside the terminal space and nowhere else. If I try to hover my mouse over the Icons, they don't light up. The only way to get out of the terminal window is to right-click the black space in the terminal window which brings up the context menu. When the context menu is brought up, I can then click on anything I want (because now the context menu has focus which somehow fixes it). If I click in the black space in the terminal window, the problem repeats.

Here is what fixes the problem until reboot:

systemctl restart ssdm.service

If I run that command, re-login, its fixed until reboot.

So either:

A. I need the proper fix. (I prefer this method please)

B. I need a way to run this command on boot.

Additional Info:

systemctl status sddm.service

Loaded: loaded (/usr/lib/systemd/system/sddm.service; enabled; vendor preset: disabled) Active: active (running) since Wed 2019-03-06 21:46:40 CST; 13h ago Docs: man:sddm(1) man:sddm.conf(5) Main PID: 5410 (sddm) CGroup: /system.slice/sddm.service ├─5410 /usr/bin/sddm └─5444 /usr/bin/X -nolisten tcp -auth /var/run/sddm/{1c6b25a2-4aa9-47de-b502-2f6d5333000a} -background none -noreset -displayfd 17 vt1

systemctl status gdm.service

gdm.service - GNOME Display Manager Loaded: loaded (/usr/lib/systemd/system/gdm.service; disabled; vendor preset: enabled) Active: inactive (dead)

0

The answer is I needed startx to run after login. Since I am running XFCE, I have available to me "Session and Startup". Start>Settings>Session and Startup. Add command:

startx

To add using command line:

mkdir ~/.config/autostart
touch ~/.config/autostart/startx.desktop
echo -e "[Desktop Entry]\nEncoding=UTF-8\nVersion=0.9.4\nType=Application\nName=startx\nComment=startx\nExec=startx\nOnlyShowIn=XFCE;\nStartupNotify=false\nTerminal=false\nHidden=false" > ~/.config/autostart/startx.desktop

This is probably not the cleanest way to do it because the screen flashes... other than that works perfect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.