1

I'm having some difficulty getting an old DDS-3 tape reader working on my Linux workstation. Some details:

  • From the product code that is printed on the label (E30364) I managed to identify the tape drive as an IBM STD224000N. It is an internal drive for which I am unable to find any online documentation. From the information here I get the impression that the IBM 7206-110 drive is basically the external variant of the same drive.

  • I've tried to hook it up to my machine using the Adaptec SCSI Card 29320LPE SCSI controller, which I have previously used successfully for external DDS-2 ands DLT-IV tape drives

  • Drive is connected to the external socket on my SCSI controller using an 68-pin VHDCI cable (i.e. even though it is an internal drive I'm using it as an external one).

  • To power the drive I'm using the DC out of this forensic write blocker.

When I connect the tape drive to my workstation, on bootup it shows:

Time-out failure during SCSI inquiry command

Then after a few more tries the screen goes blank and the machine hangs. I think the most likely cause is a termination issue, but I have literally no idea how to terminate the drive! From the documentation of my SCSI controller I understand that "termination on SE internal SCSI devices is usually controlled by manually setting a jumper or a switch on the device, or by physically removing or installing one or more resistor modules on the device".

At the back of the drive there are two sets of jumper pins:

enter image description here

  • Two rows of jumper pins on the left.
  • Three vertical jumper pins on the right.

The function of the two rows on the left is described by this label on the drive:

enter image description here

Since these settings only affect the SCSI ID, they seem unrelated to my issue (current setting set SCSI ID to 5; since I only hook up one SCSI device at a time this shouldn't cause any problems).

I cannot find any info on the three vertical pins, so I simply tried all possible jumper combinations (put jumper on pins left, then on pins right, and finally removed it altogether). None of these combinations resolve my issue.

This makes me wonder if anyone could give me any clues on how to make this work. I also recall that for some internal SCSI devices terminators were built in in the cables, but I cannot find much info on that.

  • 1
    Internal wide SCSI devices (with 68-pin connectors) usually require a separate terminator, which is provided on the cable; see here for an example. Have you tried using your device internally with such a cable? – Stephen Kitt Mar 7 at 16:54
  • @StephenKitt Thanks, this is exactly what I was looking for! The only cables I currently have are external ones without built-in termination, so I'll go out and buy a cable like this one. – johan Mar 7 at 17:08
  • 1
    @johan For active termination and termination power see jumper settings 11-12/15-16 on this page (STD224000N) and this pdf (Seagate STD224000N). Strange is that these documents say there is a dip-switch block and a jumper block (and your scsi id is jumpered). – Freddy Mar 7 at 17:36
  • @freddy Brilliant, I just applied the jumper settings according to the document you linked to, and my machine now instantly recognises the drive. Thanks! – johan Mar 8 at 12:42
2

If you don’t specifically require using the drive externally, I think the simplest approach is to connect it internally with an appropriately terminated cable, as is typically required for internal wide SCSI devices (with 68-pin connectors). You can see an example of such a cable here.

Adapting an internal wide SCSI device for external use usually involves a specific enclosure (which takes care of power, termination, and ventilation). That could be an option, if you have another external drive whose enclosure can be re-purposed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.