0

Since i upgraded my workstation from fedora28 to fedora29 i encountered a problem with my virtual machine which is running on my workstation. I am using this virtual machine for browsing in the internet.

My problem is that it seems like the time is running faster on the virtual machine than on my workstation. For example spotify or some videos are faster than normal.

Here is how i start this machine:

/usr/bin/qemu-system-x86_64 -cpu host -smp cpus=4 -hda /space/vm/images/browser.img -hdb /space/data/$USER/.browser_home.img -machine accel=kvm -daemonize -balloon none -vnc 127.0.0.1:0 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x6.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x6 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x6.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x6.0x2 -k de -m 2500 -net nic,model=virtio -net user,hostfwd=tcp:127.0.0.1:2233-:22 -monitor telnet:127.0.0.1:4444,server,nowait

I have no idea how to start debugging this one. What should i try?

  • Do you have any actual evidence that this is the case, such as comparing the output of date on the host and guest? How is time keeping done on the guest? – Kusalananda Mar 7 at 8:42
  • date seems similar, i guess the virtual guest should get his time from my host. And i think date confirms that but even if i configure ntp it is faster. @Kusalananda – Julian Mar 7 at 8:55
  • It is "similar" and "faster" at the same time? You mean the video runs faster? In that case it's probably not a time problem but an issue with the speed of the video playback. – Kusalananda Mar 7 at 8:56
  • output of date seems to be similar, yes. But if i open spotify, youtube and so on, the time definately runs faster. not much, but it runs faster. And it definately has to do with fedora29. – Julian Mar 7 at 9:04
0

The solution is the virtual soundcard. Thats how i manage to get the sound from the VM to my host. But it seems like the soundcard calculates the wrong status.

-device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0

The working way is to replace the settings with this.

-soundhw es1370

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.