0

I just upgraded Fedora using the system upgrade dnf plugin and everything went fine up until the first boot where I got stuck with a black screen and just a moving cursor. journalctl -u lightdm doesn't report any errors nor is there any EE in /var/log/xorg.0.log except for one that reads:

modeset(0): Invalid argument

Before upgrading (and after updating Fedora 28) I was running kernel 4.20.11-100 and after the upgrade I was on kernel 4.20.13-200.

I tried booting with kernel 4.20.13-200 (the last one before the upgrade -- that still reads Fedora 28) and I can now see the password prompt and LightDM (apparently) works fine, but many things in the session are broken now (missing shared libraries, some ABRT warnings about processes crashing, etc.).

I also noticed that with this kernel, in /var/log/xorg.0.log in the part where it said modeset(0): Invalid argument it now says:

modeset(0): EDID vendor "ACR", prod id 821
modeset(0): Using EDID range info for horizontal sync
modeset(0): Using EDID range info for vertical refresh
...

And it goes on to list all the valid resolutions for both monitors (I'm running a dual-head setup)

What could be the problem? I tried reinstalling lightdm, the gtk-greeter, even the intel xorg drivers (I'm not using a dGPU).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.