1

I want to use vim over nano as default text editor. I tried to do it with

sudo update-alternatives --config editor

From menu I chose vim. However, when I open any file, Linux launches nano just as before. What am I doing wrong?!

  • How did you try to open the file? Could you add the output of update-alternatives --display editor to your question? What happens when you run the editor command? – sborsky Mar 6 at 21:14
  • Did you relogin? – bodqhrohro Mar 6 at 21:59
  • @sborsky I open the file in Midnight Commander – Em Ka Mar 7 at 19:04
  • @bodqhrohro Yes, I did relogin – Em Ka Mar 11 at 19:38
  • @EmKa Midnight Commander has it's own settings for opening files in some programs. Go to Command -> Edit extension file to change it. By the way, the extension file itself should open in the editor you have already configured system-wide. – bodqhrohro Mar 11 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.