0

i use the last linux mint XFCE, i'd like my laptop to shut down when i close the screen. How can i achieve that ?

I've tried to uncomment and set HandleLidSwitch=poweroff in logind.conf i restarted the computer then.

I've also tried to set lid-close-ac-action & lid-close-battery-action to shutdown in dconf editor but nothing works.

0

You need to edit the file /etc/systemd/logind.conf and change the following line to this:

HandleLidSwitch=poweroff

You will need to run systemctl restart systemd-logind.service or restart your laptop to enable the setting.

  • I did this already but it does not work, my laptop don't stop – user1758935 Mar 6 at 18:06
  • @user1758935 this could be a bug with your hardware. I am seeing that some people have to take additional steps. Confirm that you have pm-utils, xfce4-power-manager, and edit your post to include all of your hardware. Make, Model, chipset, graphics, usb devices, etc. – kemotep Mar 6 at 18:22
  • After logind.conf edit, I had to re-change laptop lid behavior in xfce4-power-manager and then it worked. – user1758935 Mar 8 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.