0

I have a problem when running rsnapshot for backing up a network mapped drive directory to my local client via cron (and only via a scheduled job). If I run rsnapshot in a CYGWIN terminal manually I get not errors, while when running via a cron job I get this weird error log:

[2019-03-06T13:30:07] /usr/bin/rsnapshot -c /etc/defaults/etc/rsnapshot.conf alpha: ERROR: ---------------------------------------------------------------------
[2019-03-06T13:30:07] /usr/bin/rsnapshot -c /etc/defaults/etc/rsnapshot.conf alpha: ERROR: Errors were found in /etc/defaults/etc/rsnapshot.conf,
[2019-03-06T13:30:07] /usr/bin/rsnapshot -c /etc/defaults/etc/rsnapshot.conf alpha: ERROR: rsnapshot can not continue. If you think an entry looks right, make
[2019-03-06T13:30:07] /usr/bin/rsnapshot -c /etc/defaults/etc/rsnapshot.conf alpha: ERROR: sure you don't have spaces where only tabs should be.
[2019-03-06T13:45:02] /usr/bin/rsnapshot -c /etc/defaults/etc/rsnapshot.conf alpha: ERROR: /etc/defaults/etc/rsnapshot.conf on line 227:
[2019-03-06T13:45:02] /usr/bin/rsnapshot -c /etc/defaults/etc/rsnapshot.conf alpha: ERROR: backup \
         /cygdrive/N/<source_here>/ \
         localhost/ - Source directory \
         "/cygdrive/N/<source_here>/" \
         doesn't exist 

I double checked the source directory address, which is: /cygdrive/N/.../, even with the command

rsnapshot /etc/defaults/etc/rsnapshot.conf configtest

which ended with a Syntax OK statement. Again, no issues when running manually, problems when running as a scheduled job. Any idea? Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.