0

I switched my DM from LightDM to GDM and now I cannot launch gnome-terminal. When I try to launch it from another terminal emulator, I get this error message:

# Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

I suspect it has something to do with my location, but my lang is set to en_US.UTF-8

<~>-> locale
LANG=en_US.UTF-8
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=C
<~>-> 
  • I’ve seen GNOME Terminal not starting while LC_ALL=C was in effect. I then switched to using LC_COLLATE=C and LC_NUMERIC=C, which for my purpose were enough. If that works for you, too, and brings back GNOME Terminal, I can see about converting this to an answer. – Phoenix Mar 5 '19 at 22:09
1

I'm not sure what exactly I did to fix this, but I think it was some combination of:

sudo locale-gen --purge
sudo locale-gen
localectl set-locale LANG="en_US.UTF-8"
sudo fc-cache -f -v
| improve this answer | |
1

I also had this problem, and was very frustrated because set-locale LANG="en_US.UTF-8" resulted in no changes in locale.

The fix: Add these lines to /etc/environment:

LC_ALL=en_US.UTF-8
LANG=en_US.UTF-8

Then reboot. Note that exporting these settings in .bashrc did not work.

| improve this answer | |
  • I found later that my .bashrc file had these set to =C, and the environment settings could override this. So I should have looked there first. – Bret Hess Nov 22 '19 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.