0

when I run KDE Plasma inside a VM (oVirt/qemu) with qxl enabled, systemsettings5 just show two black frames. This seems to be independent of the OS (tested on Gentoo Linux and Ubuntu). Plasma Desktop version is 5.14.5.1. The log messages are:

WARNING: viewBackgroundColor is deprecated, use backgroundColor with colorSet: Theme.View instead
WARNING: viewBackgroundColor is deprecated, use backgroundColor with colorSet: Theme.View instead
KActivities: Database connection: "kactivities_db_resources_140017328429056_readonly" 
    query_only:          QVariant(qlonglong, 1) 
    journal_mode:        QVariant(QString, "wal") 
    wal_autocheckpoint:  QVariant(qlonglong, 100) 
    synchronous:         QVariant(qlonglong, 0)
Nothing to load - the client id is empty
Nothing to load - the client id is empty`

If relevant, I put some information about glx here:

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
GLX version: 1.4
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: VMware, Inc. (0xffffffff)
    Device: llvmpipe (LLVM 7.0, 128 bits) (0xffffffff)
    Version: 18.2.2
    Accelerated: no
    Video memory: 7784MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 7.0, 128 bits)
OpenGL version string: 3.1 Mesa 18.2.2
OpenGL shading language version string: 1.40
OpenGL context flags: (none)

and about the xorg configuration here:

Section "Device" 
    Identifier "qxl"
    Driver     "qxl" 
    Option  "DPI"   "96 x 96" 
    Option "ENABLE_IMAGE_CACHE" "True" 
    Option "ENABLE_FALLBACK_CACHE" "False" 
    Option "ENABLE_SURFACES" "False" 
EndSection

Changing to fbdev or vesa did not fix the problem.

systemsettings5 with blank frames

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.