0

I tried to practice on autofs and something do not work as excepted. I have the following Scenario :

Debian NFS SERVER : 192.168.1.32 Centos7 nfs Client: 192.168.1.99

/etc/exports on NFS SERVER :

/var/nfs/public 192.168.1.0/24(rw,no_root_squash)

/etc/auto.master on Centos7 Client:

/pub /etc/auto.nfsdb

/etc/auto.nfsdb:

* -rw 192.168.1.32:/var/nfs/public

Service is on , can access to the /pub folder on the Client, but can not write to her or even when i do ls -l on the files on the directory , nothing is show.

[root@localhost pub]# ls -l
total 0

[root@localhost pub]# mkdir 1
mkdir: cannot create directory ג€˜1ג€™: Permission denied

/var/log/message :

Mar 4 06:43:36 localhost automount: master_do_mount: mounting /net
Mar 4 06:43:36 localhost automount: automount_path_to_fifo: fifo name /run/autofs.fifo-net
Mar 4 06:43:36 localhost automount: lookup_nss_read_map: reading map hosts (null)
Mar 4 06:43:36 localhost automount: do_init: parse(sun): init gathered global options: (null)
Mar 4 06:43:36 localhost automount: lookup_read_map: lookup(hosts): read hosts map
Mar 4 06:43:36 localhost automount: lookup_read_map: lookup(hosts): map not browsable, update existing host entries only
Mar 4 06:43:36 localhost automount: mounted indirect on /net with timeout 300, freq 75 seconds
Mar 4 06:43:36 localhost automount: st_ready: st_ready(): state = 0 path /net
Mar 4 06:43:36 localhost automount: master_do_mount: mounting /pub
Mar 4 06:43:36 localhost automount: automount_path_to_fifo: fifo name /run/autofs.fifo-pub
Mar 4 06:43:36 localhost automount: lookup_nss_read_map: reading map file /etc/auto.nfsdb
Mar 4 06:43:36 localhost automount: do_init: parse(sun): init gathered global options: (null)
Mar 4 06:43:36 localhost automount: mounted indirect on /pub with timeout 300, freq 75 seconds
Mar 4 06:43:36 localhost automount: st_ready: st_ready(): state = 0 path /pub
Mar 4 06:43:36 localhost systemd: Started Automounts filesystems on demand.

nsswitch.conf :

automount: files nis nisplus sss

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.