0

I am trying to mount a remote folder using sshfs. It works great besides the umask being incorrect.

When I create a file or folder I get the equivalent of 0022 for rwx r-x r-x.

I want equivalent of 0000 for testing purposes (rwx rwx rwx).

I tried adding umask=0000 as a sshfs argument but doesn't make a difference. I tried updating /etc/profile and .bashrc adding umask 0000 in those files and that doesn't work.

I am stumped. Maybe samba mount is a better method (I just didn't want to go through installing samba, setting up shares/users, etc)? Just looking for a secure way to basically file share.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.