0

I get this error when running 'startx'. What is this 'nv' module, and how do I stop Xorg from trying to load it?

EDIT: I am going to try to blacklist the module 'nv' using the kernel command line. I'll update this post if that works.

I installed the Nvidia drivers, nouveau drivers and intel drivers. I also added the Nvidia drivers to /etc/mkinitcpio.conf (in MODULES). I'm on the latest version of Arch Linux.

What I tried:

  • Created the xorg.conf file using nvidia-xconfig. On doing 'startx', nothing happens until I type 'exit'
  • Deleted the xorg.conf file. It yields the nv module error

Also, is there a way to use the intel drivers instead of the nvidia drivers? I'd like to use this as a last resort.

  • see askubuntu.com/q/90915 Do you have a Nvidia graphics card? Maybe you have to install a (non-free) driver for this. – Bodo Mar 4 at 17:31
  • @Bodo Yes, I have an Nvidia graphics card. I installed Arch Linux before, with the Nvidia drivers and KDE and it worked. And now I'm reinstalling Arch Linux, but this time with XFCE, and it doesn't work (i.e. gives that error). – Alsan Ali Mar 4 at 17:35
  • Please add this information to your question. Did you install Nvidia drivers? Did you install the new system on the same hardware? Did you install a new version of Arch Linux? – Bodo Mar 4 at 17:38
  • @Bodo Done. Added that info – Alsan Ali Mar 4 at 17:43
  • Do you have an xorg.conf file? Does it reference nv? – Bodo Mar 4 at 17:50
0

It turned out that the 'nv' module wasn't really the problem at all. All I had to do was remove the unnecessary lines like 'xterm' from .xinitrc, and XFCE finally started. Sure, the error is still there, but it doesn't really do anything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.