0

I have a Debian i386 system, recently updated to 9.8 stretch. I need to install libc6_2.28 for an application, but the system doesn't. If I run

sudo apt-get -f install libc6

the result is: 2.24-11+deb9u4

even though when I check the version

cat /etc/debian_version

the answer is 9.8.

2

Debian 9.x "stretch" uses version 2.24 of libc6. The current version is 2.24-11+deb9u4, i.e. it includes a lot of patches and backported security bugfixes compared to upstream version 2.24. The deb9u4 part indicates this packaged version may have some dependencies requiring the system as a whole to be at Debian 9.4 or above.

Warning: libc6 is a pretty fundamental package that is used by essentially all system binaries. Debian buster (i.e. the current testing) has version 2.28 of libc6, but you should not install it to stretch.

Don't make a FrankenDebian

Debian Stable should not be combined with other releases. If you're trying to install software that isn't available in the current Debian Stable release, it's not a good idea to add repositories for other Debian releases. The problems might not happen right away, but the next time you install updates.

The reason things can break is because the software packaged for one Debian release is built to be compatible with the rest of the software for that release. For example, installing packages from buster on a stretch system could also install newer versions of core libraries including libc6. This results in a system that is not testing or stable but a broken mix of the two.

What you are trying to do is exactly "installing a newer version of core library libc6". This is known to break things. Don't do it (unless you're updating the entire system to buster of course).

If an application requires libc6 version 2.28 or higher, then it is not compatible with Debian 9.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.