1

I'm getting the following when installing @sentry/cli@1.39.1 in a fresh node_modules (existing project). Needed for @sentry/webpack-plugin.

Is there any way I can find out more about this "unknown system error -122"? The npm debug log has no more info on the error than below.

user@host ~/project $ rm -rf node_modules
user@host ~/project $ npm install --no-save @sentry/cli@1.39.1

> @uirouter/core@5.0.5 install /home/user/project/node_modules/@uirouter/angularjs/node_modules/@uirouter/core
> node ./migrate/migratewarn.js


> strong-ursa@0.10.1 install /home/user/project/node_modules/strong-ursa
> node-gyp rebuild

make: Entering directory '/home/user/project/node_modules/strong-ursa/build'
  CXX(target) Release/obj.target/ursaNative/src/ursaNative.o
  SOLINK_MODULE(target) Release/obj.target/ursaNative.node
  COPY Release/ursaNative.node
make: Leaving directory '/home/user/project/node_modules/strong-ursa/build'

> @uirouter/angularjs@1.0.5 install /home/user/project/node_modules/@uirouter/angularjs
> node migrate/migratewarn.js


> @sentry/cli@1.39.1 install /home/user/project/node_modules/@sentry/cli
> node scripts/install.js

fs.js:1918
  binding.copyFile(src, dest, flags);
          ^

Error: Unknown system error -122: Unknown system error -122, copyfile '/home/user/.npm/sentry-cli/75353c-sentry-cli-Linux-x86-64' -> '/home/user/project/node_modules/@sentry/cli/sentry-cli'
    at fs.copyFileSync (fs.js:1918:11)
    at downloadBinary (/home/user/project/node_modules/@sentry/cli/scripts/install.js:112:5)
    at Object.<anonymous> (/home/user/project/node_modules/@sentry/cli/scripts/install.js:178:1)
    at Module._compile (module.js:653:30)
    at Object.Module._extensions..js (module.js:664:10)
    at Module.load (module.js:566:32)
    at tryModuleLoad (module.js:506:12)
    at Function.Module._load (module.js:498:3)
    at Function.Module.runMain (module.js:694:10)
    at startup (bootstrap_node.js:204:16)
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! @sentry/cli@1.39.1 install: `node scripts/install.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the @sentry/cli@1.39.1 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
0

I had this same error when I upgraded node to > v8

fs.js:1919
  binding.copyFile(src, dest, flags);

The solution was to upgrade my npm packages using npm audit fix I am not sure which of the many packages upgraded solved the problem

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.