0

I am unsuccessfully trying to install Ninja-IDE (a lightweight Python IDE) using the .DEB file which I downloaded from their website: http://www.ninja-ide.org/downloads/. It seems that a dependent package cannot be installed for some reason (python-qt4).

I used the following command:

sudo dpkg -i ninja-ide_2.3+r597_saucy1_all.deb

which results in:

(Reading database ... 88968 files and directories currently installed.)
Preparing to unpack ninja-ide_2.3+r597_saucy1_all.deb ...
Unpacking ninja-ide (2.3+r597~saucy1) over (2.3+r597~saucy1) ...
dpkg: dependency problems prevent configuration of ninja-ide:
 ninja-ide depends on python-qt4; however:
  Package python-qt4 is not installed.

dpkg: error processing package ninja-ide (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:
 ninja-ide

followed by:

sudo apt-get install -f

Then I get this (last message): E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

So I tried running apt-get update, apt --fix-missing install and apt --fix-broken install again, but nothing seems to work! When I ran apt --fix-broken install, I got the following message (for other packages as well, but I'm only showing it for python-qt4):

E: Failed to fetch http://mirror.iway.ch/raspbian/raspbian/pool/main/p/python-qt4/python-qt4_4.11.4+dfsg-2_armhf.deb  Hash Sum mismatch
   Hashes of expected file:
    - SHA256:e6f7626a33b897988413815bc0a104b0a2c19148349e8b13d8e7ca8210a8ab36
    - SHA1:46a7279c10036fc92adddba5184aee1934069611 [weak]
    - MD5Sum:f225570812e8839fbb516cb958e44da7 [weak]
    - Filesize:1695326 [weak]
   Hashes of received file:
    - SHA256:e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
    - SHA1:da39a3ee5e6b4b0d3255bfef95601890afd80709 [weak]
    - MD5Sum:d41d8cd98f00b204e9800998ecf8427e [weak]
    - Filesize:0 [weak]
   Last modification reported: Tue, 31 May 2016 14:48:15 +0000

But I have no idea how to interpret this.

I am using Raspbian.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.