0

I'm using Debian 9 x64 with the dwm window manager. I don't use Gnome, KDE, Xfce, or any other desktop environment; it's just the window manager.

I configured my keyboard layout to use the Generic 105-key international keyboard. I've tried AltGr (the right Alt key) plus various alt codes, to no avail. I've also tried AltGr and then " u or u ", with similarly disappointing results.

Ideally I would be able to type these characters anywhere, including text editors (all of mine support Unicode), web browsers, etc. I don't use LibreOffice, so some of the LibreOffice-specific solutions I find aren't enough.

2 Answers 2

5

You're missing a step. You need to set a Compose key first. For example, to set the right Alt key as the Compose key:

setxkbmap -layout us -option compose:ralt

Then:

  1. Press Compose (on my keyboard it's labelled Alt Gr) and release it.
  2. Press the sequence of keys that correspond to the letter/diacritic you want. These are sometimes intuitive, sometimes not. Sometimes the order doesn't matter, either, e.g. in the case of accents.
    • To insert ß, press s s
    • For umlauts, e.g. ü, press u "
    • For accents, e.g. á, press a ' or ' a
    • For ñ, press n Shift ~

You can see the full list on Wikipedia or in the image below:

compose key: common combinations

-1

If it is for a few char, you can use :

Ctrl+Shift+U Enter 'utf8 code of your char' Enter

You can find the utf8 code here

1
  • 1
    This works in programs that support it, e.g. Firefox, but it doesn't work everywhere (in some terminals, for example, or the SciTe text editor without additional modification).
    – Michael A
    Commented Mar 2, 2019 at 17:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .