2

System: Linux Mint 19.1 Cinnamon.

Hardware: Laptop screen: 3840x2160 + HDMI screen 1920x1080.


I have enabled Double DPI in General settings. It works fine for the laptop display, but now I connected an external FullHD display, the things on it are twice as large.

I currently use the following command to correct the scaling:

xrandr --output HDMI-0 --scale 2x2

My intention is to make this permanent and persistent on reboots etcetera.

How and in what file can I do this?


I have tried to look for an xorg.conf, but this is what I only get:

$ locate -i xorg.conf

/usr/share/X11/xorg.conf.d
/usr/share/X11/xorg.conf.d/10-amdgpu.conf
/usr/share/X11/xorg.conf.d/10-nvidia.conf
/usr/share/X11/xorg.conf.d/10-quirks.conf
/usr/share/X11/xorg.conf.d/10-radeon.conf
/usr/share/X11/xorg.conf.d/11-nvidia-prime.conf
/usr/share/X11/xorg.conf.d/40-libinput.conf
/usr/share/X11/xorg.conf.d/70-wacom.conf
/usr/share/doc/xserver-xorg-video-intel/xorg.conf
/usr/share/man/man5/xorg.conf.5.gz
/usr/share/man/man5/xorg.conf.d.5.gz

Note, that I use Nvidia, so these 2 might be relevant:

$ cat /usr/share/X11/xorg.conf.d/10-nvidia.conf

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
EndSection

and this one:

$ cat /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf

# DO NOT EDIT. AUTOMATICALLY GENERATED BY gpu-manager

Section "OutputClass"
    Identifier "Nvidia Prime"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    Option "IgnoreDisplayDevices" "CRT"
    Option "PrimaryGPU" "Yes"
    ModulePath "/x86_64-linux-gnu/nvidia/xorg"
EndSection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.