0

I have a problem with the installation XEN on CentOS. I did everything through virt-manager, I did not try through the commands, but there should be the same error as I understand it. Worth the graphics subsystem, LXQT, lightdm, 4.9.127-32.el7.x86_64 GNU/Linux.

I get the following error:

Unable to complete install: 'internal error: libxenlight failed to create new domain 'win7''

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/asyncjob.py", line 89, in cb_wrapper
callback(asyncjob, *args, **kwargs)
File "/usr/share/virt-manager/virtManager/create.py", line 2553, in _do_async_install
guest.start_install(meter=meter)
File "/usr/share/virt-manager/virtinst/guest.py", line 498, in start_install doboot, transient)
File "/usr/share/virt-manager/virtinst/guest.py", line 434, in _create_guest domain = self.conn.createXML(install_xml or final_xml, 0)
File "/usr/lib64/python2.7/site-packages/libvirt.py", line 3725, in createXML
if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
libvirtError: internal error: libxenlight failed to create new domain 'win7'

Anyone know what to do?

  • That’s not a CentOS kernel. What additional repos and software did you install? – jsbillings Mar 3 at 3:30
  • Installed epel-release, centos-release-xen. Updated. I followed this instruction: link. Then I installed the old with --enablerepo=centos-release-xen-*. Did not help. I have always tried to create through virt-manager. I just can not find an article where it would normally explain how to create virtual machines in XEN through a terminal. Someone manually writes a config, someone uses virt-install. It is not clear how to correctly. And about the parameters there are ambiguities. Maybe someone knows a really good article or manual? – Alex. A Mar 3 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.