1

Using Linux Mint 19 64-bit here.

I'm experiencing a bug in current LibreOffice versions (6.2.0.3, but it's apparently been around since 5.x.) A known good version with regards to this bug can be found at https://downloadarchive.documentfoundation.org/libreoffice/old/4.3.7.2/deb/x86_64/ .

So I downloaded LibreOffice_4.3.7.2_Linux_x86-64_deb.tar.gz from there and installed it using dpkg, which worked fine, and without errors.

But launching it fails silently just after the splash screen comes up (so fast that Peek didn't even capture the splash screen, even though it was there for maybe 50-100ms): launching from a terminal gives no clues

Launching 6.2.0.3 from a sibling directory this way works just fine.

What might be killing it? I found this in the syslog:

kernel: [ 137.651100] traps: soffice.bin[4736] general protection ip:7f2c6be910c0 sp:7ffd85092068 error:0 in libpangoft2-1.0.so.0.4000.14[7f2c6be89000+14000]

  • Did you install the necessary dependencies after installing the .deb? – Peschke Feb 28 at 7:59
  • @Peschke It seemed to be self-contained--the DEBS directory of the zipfile has dozens of .debs, and I used dpkg -i *.deb per their instructions. The exact same method worked for 6.2.0.3. – Kev Feb 28 at 10:45
  • The fact it installed without errors suggests there's no detected problem with dependencies. – Philip Couling Feb 28 at 10:55
  • 1
    I'm wondering what to suggest. The challenge is that when a package (.deb) is built the maintainer can know its dependencies and record them in the pacakge. However the maintainer can't look into a crystal ball to find out when dependencies will break because of upgrades. Archived versions won't necessarily run on new systems without downgrading some things on your system. The dependency manager (dpkg) won't be able to tell you what to downgrade because the the maintainer from 2015 didn't know how to make it work in 2019. – Philip Couling Mar 1 at 10:27
  • 1
    There's an ugly chance that the only two ways to get this running might be 1) downgrade your entire system to one from 2015 or 2) find the source code from 2015 and compile it yourself against your newer system. – Philip Couling Mar 1 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.