So I recently installed another NVMe SSD into my computer and my Arch Linux will no longer boot. Here is the message I receive immediately after booting:

enter image description here

Here is a copy of what my fstab looks like:

enter image description here

In addition note that my system is dual boot with Windows, my boot loader is GRUB.

Also note that after looking into some forums there was an issue with LVM2 a few months ago, see: https://www.reddit.com/r/archlinux/comments/8y2xas/file_system_dependency_not_found_on_boot_yet_the/

I think what has happened is that my boot sequence is looking for root, /home and swap in nvme0n1p*, but installing another NVMe SSD has changed the SSD name of the drive that had Linux on it to nvme1n1p* (Note the change from 0 --> 1)! How do I tell the boot sequence to look in the correct partition on the correct drive?

  • -3 in 2 minutes, what is wrong with my question?
    – Decebalus
    Commented Feb 27, 2019 at 20:27
  • Well... Welcome on U&L! I did not downvote, but here are my thoughts: 1) Users on U&L expect questions to show research effort. Saying that you "forgot", "can't" or "don't remember" may be seen as a lack of such effort or, worse, as a refusal to make any effort. 2) Posting images is really not well received and likely attract downvotes. 3) Even without these issues, questions that seem to ask for step by step guidance in troubleshooting usually don't score high.
    – fra-san
    Commented Feb 27, 2019 at 21:13
  • I see, well that's a bit annoying since all I've been doing for the past 3 hours is reading forums about this. I don't know how to paste in the output from the command line since I am using a different computer to post this question, and I don't see how manually typing it out is a reasonable request. Regardless please see my edit as I think I found the problem I just don't know how to fix it!
    – Decebalus
    Commented Feb 27, 2019 at 21:22
  • (Actually, posting images in these circumstances is a valid exception to the general rule). I can't post an answer right now. Yes, your issue is probably in how your system is naming your devices. You should use lsblk and blkid to identify your current partitions, update your fstab using UUIDs - the Arch Wiki is your friend - and update your initramfs with mkinitcpio -p linux.
    – fra-san
    Commented Feb 27, 2019 at 21:35
  • Thanks for the help! Actually I have just done that, I checked the UUIDs and they all seemed correct using the commands you just mentioned. I tried directly editing the fstab file using nano and it worked! It was exactly the problem that I mentioned above, I simply changed the 0->1 after 'nvme' in the fstab file. However I want to ensure that this is a 'good' way to fix my problem, since I manually edited the fstab file.
    – Decebalus
    Commented Feb 27, 2019 at 21:38

1 Answer 1


I found a solution to my problem:

The drive and partition that had my arch linux installation on it was renamed from nvme0** to nvme1** after installing an additional nvme drive into my computer. I fixed my issue by simply directly editing my fstab file located in /etc using nano and manually changing the 0 --> 1, so that the boot sequence was actually looking in the correct location for my root, /home and SWAP partitions.

Hopefully this helps someone if they ever encounter this bizarre issue!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .