0

I am using Debian 9 with an older Radeon GPU (5450). I am interested in using the snap package of ffmpeg (which is version 4.1) because of some issues I may be able to fix with the newer snap instead of the Debian version (which is version 3.2.12-1~deb9u1). I have installed the snap package but receive the following error.

~$ ffmpeg
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error:  GLXBadContext
  Request Major code 155 (GLX)
  Request Minor code 6 ()
  Error Serial #49
  Current Serial #48

The snap package does not work properly for me in Debian 9. For example, it does not detect my microphone. I will plan to report this bug, but I am curious if anyone has any ideas for a workaround.

  • 1
    not using a snap package and the actual ffmpeg package? yeah, I have read the question. I would try to use the one from buster or compile it before using a snap. – Rui F Ribeiro Feb 27 at 19:28
  • It is not in the stretch-backports. I might plan to compile. – jbrock Feb 27 at 19:36
  • I think in the past Ĩ also compiled it for Armbian. – Rui F Ribeiro Feb 27 at 19:40
  • 1
    @RuiFRibeiro Compiling fixed my original issue. :) I'll plan to post my steps later on. I guess compiling can be a "workaround" as well. – jbrock Feb 27 at 23:23
  • good news then. – Rui F Ribeiro Feb 27 at 23:30
0

My solution was to compile the newest version of ffmpeg. I use ffmpeg for screencasting, video compression, webcam recording, and film trimming. Therefore, it is likely you may need other options which you can see by running the following in your ffmpeg source folder:

./configure --help

Here were my options:

./configure --prefix=/usr/local --enable-libxcb-xfixes --enable-libxcb --enable-gpl --enable-nonfree --enable-libx264 --enable-libfdk-aac --enable-libmp3lame --enable-libopus --enable-libpulse

I first needed to install these dependencies:

sudo apt install libx264-dev libfdk-aac-dev libmp3lame-dev libopus-dev libpulse-dev libxcb1-dev libxcb-xfixes0-dev

I still have the Debian 9 ffmpeg version installed. I just did a symbolic link to my ~/bin with:

sudo ln -s /usr/local/bin/ffmpeg $HOME/bin/

With the symbolic link, the system will default to the latest version instead of the version in /usr/bin/ffmpeg.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.